Hello all
I just purchased a beaglebone black RevC with 4gb eMMC onboard. I’ve connected it via RJ45 and usb host port to my pc. Copied the onboard script onto my desktop and used “chmod +x” and then “./”. Tried to access the board with “” and “”. It times out everytime and i am not able to access the board. Please help.

The udevrule:

doesn't apply to the BeagleBone Black..

It's only useful for the old original "BeagleBone" aka the white..

Back before we got it's id pushed to mainline.. (back in the 2.6.x/3.x era)

For most distro's, out of the box you should either see 1 or 2 new
interfaces by running:

sudo ifconfig -a

if not, just save yourself by reflashing with the latest "monthly"
jessie snapshot:

use to help flash the microSD card.


No, i think you have misunderstood me. I meant i installed the udev rules that already existed onboard the beaglebone black in the “drivers” folder. The beaglebone also did not work before i did this. Regardless, i have solved this problem. The builtin network manager in Ubuntu was giving me troubles so i switched it out to “WICD” earlier this month. I guessed WICD was causing the problem, so reinstallled the network manager and uninstalled WICD and it works like a charm! I am now able to completely access it and have started tutorials. Thanks for the help! By the way, which language do you think i should work on, considering i have some experience with Embedded C and Atmel AVR’s ? And, it would be a great help if you could send me some links to books in that language.