beaglebone black not being detected when plugged in through USB cable

I have Windows 7 and Ubuntu 14.04 on VM installed on my computer. I have successfully established a ssh communication between my Beaglebone Black Element 14 Rev C and computer. I was recently trying to install Python library from adafruit's website from their tutorials. The library was to help the user to access the GIOPs and generate PWM.

Today when I plug my beaglebone into my computer using USB cable, the beagle is not recognized/detected by the computer. I tried different computers and different cables. The current cable is working fine. The Beaglebone Black is even powered up and flashes its LEDS in the normal progression like it should but it is just not being detected by the computer.

Is it something to do with the hardware? Can this issue be solved?

I will appreciate your help.

As far as I know, there is a known problem related to hot plugging USB devices at BBB.
Try connecting Desktop computer before restart the board.

@Nova Jack

Did you change anything recently ? e.g. change Linux images, or update the kernel ?

The only thing I did was to follow this tutorial of adafruit : to install Python library. Even after installing it it was working. I had plugged and unplugged it from my computer through the USB cable. But the problem now I face is that the computer doesn’t detect the presence of any device connected to it once I plug in the beagle.

I plugged in different flashdrives through the same port, same computer, same cable - they work. The beagle refuses to budge. I was thinking of flashing an image now - as being the last resort - but can i flash a new image from the SD card even when the beagle is not detected by the computer? Sure, it powers up and the leds lit up in the normal way they do. What do you suggest?​

A problem like this is hard to solve . . . from over here . . . without any solid information. As it stands, the only thing I can think of. Would be to somehow log into the beaglebone. The only way that comes to mind is by using a serial debug cable / device.

There are surely many potential causes for this problem. But without logging in somehow and troubleshooting directly on the beaglebone . . . Yeah that just turns into hit /miss guessing.

Thanks for the input! I’ll look into that. I’m thinking maybe there is a hardware problem. Because I have never experienced a problem like this. Normally the devices are recognized by the computer and one can start from there. But anyway, thank you again. Everyone, for your answers.

Have you got a 5V power supply? I found that although a USB connection lit up all the lights, it didn’t work properly until I connected the 5V power supply.

Are you running a TI kernel? I think by default these are build with USB gadget support enabled for both CDC ECM and RNDIS.
I have found that if CDC ECM support is enabled in the kernel then usb/ethernet does not work with the windows driver. To
fix this I rebuild the TI kernel from source (on an x86/Linux host), disabling CDC ECM support then copy the generated loadable
kernel object (g_multi.ko) onto the bone.

Cheers Steve