BeagleBone Black not booting up when trying to boot with micro SD card

I made a minimal yocto build for beaglebone black and flashed it on a microsd card manually. When I tried to boot it while powering up and holding down S2. None of the bulbs light up when I do this (only the power one does which stops if I don’t connect the board to my laptop and try to boot from just an adapter). The board is booting from onboard e-MMC when I connect it to my laptop (not booting through adapter).

What is your MACHINE=

source your build then

$bitbake-layers show-layers

Hi there,
By default, BBBlack should prioritize boot up to microSD card.
I don’t know how you manually flash your image to microSD card but here is my advice:

  1. You should use a microSD card storage <=32GB in case need to flash image from microSD to eMMC (larger storage may cause failure during flash process)
  2. You should use “balenaEtcher” software to flash your image to microSD card (balenaEtcher will extract the image, format the microSD card, and flash the image to microSD card)
  3. It is recommended to power up BBBlack with 5V adapter under normal working condition or flashing image to BBBlack. USB is recommended for communication with PC.
  4. You can download image from this forum to test your device both “eMMC flasher image” and “microSD image”
    Debian 11.x (Bullseye) - Monthly Snapshot - 2023-09-02

I used a 32 GB microSD card, Didnt think of using Balena Etcher will try that
btw my build was core-image-minimal
I created two partitions namely boot and root in boot I placed MLO and Uboot and in root I extracted the rootfs
this should have worked

Sorry my bad, BBBlack boots eMMC by default.
Hold down the boot button before applying power to boot from microSD card.

In case of nothing happens or any failures, read messages from BBBlack J1 serial could help. You may need FTDI module (BBBlack’s serial signals level are 3.3V. Refer to board’s user manual for detail) to transfer data from BBBlack to PC.
Good luck!