Beaglebone Black: Qt on EGLFS platform display problem. How to disable cmdline (console) output?

Hello everyone

I’m new to arm Linux and Qt. What I am doing is to cross compile Qt on BBB with EGLFS support. Now, I’ve successfully built Qt 5.4 source for Kernel 3.18 and the applications works fine. However, it seems that the cmdline output is interfering with the Qt app’s output. When I run a Qt app on BBB, the app basically covers whole screen, but the cursor of the cmdline is still flashing thus there is one character size area of black color with a cursor flashing on the screen. Sometimes even the whole cmdline screen will come out for a tiny period. My understanding is that the cmdline keeps refreshing part of the screen so it collides with Qt app’s screen. My question is: is there a way to disable cmdline’s output when we execute Qt’s app?

I searched this for solution but no results. Some say that if I add “console=” to uEnv.txt will disable the console’s output. However, no matter how I modify the uEnv.txt, the cmdline still shows up on the screen. Some say that I need to remove “console=tty0” line in uEnv.txt. However, I followed the image build process on eewiki BBB website. Based on the instruction, the uEnv.txt only contains one line, which is the kernel version. So, there’s nothing to remove.

Could someone help me with this problem? Thanks!


Latest debian uEnv.txt has changed to /boot;

and /boot/uboot/dtbs has changed to /boot/dtbs/3.8.13-bone70下了

"console=tty0" is normally not there by default..


Sorry, this is not a solution for me. I use kernel 3.18 and Ubuntu file system. I followed the instruction on eewiki BBB website to build image. The uEnv.txt is in /boot. Thanks!

Hello Robert,

I know “console=tty0” is not there because I followed the instructions on eewiki BBB. Is it possible to set “console” to some value to disable its output to display? Thanks!


Just disable the hdmi in the uEnv.txt file.