BeagleBone Black - Unable to access built-in web apps

New BBB user. Connecting the BBB to a Debian GNU/Linux box via the BBB USB port. No Ethernet or Wi-Fi connection to the Linux box. On the Linux box, the BBB has assigned to it an IP of

Using Firefox-ESR on the Linux box, I connect to & get the BBB web page with the four web apps installed on the BBB. However when clicking any of those links other than BeaglePlay-io.html Firefox returns “can’t access”.

Typing in the direct address or direct URL ( or http://beaglebone.local/VSCode.html for example) gives the same result.

Have tried this as well with the BBB configured in its “stand-alone” mode and connecting to http://beaglebone.local gives the same result.

The BBB image is: Debian Bookworm IoT Image 2023-10-07.

What’s the secret sauce to accessing the rest of the apps?


been a while,
the following is from my notes for Ubuntu 18.04 Desktop
on BBB

  • the following must be done after each reboot, ssh into BBB on 7.2

required on BBB

echo “nameserver” | sudo tee /etc/resolv.conf sudo route add default gw

This is on ubuntu desktop

sudo iptables --table nat --append POSTROUTING --out-interface enp0s25 -j MASQUERADE
sudo iptables --append FORWARD --in-interface enxb0d5cccd8ab8 -j ACCEPT
echo 1 | sudo tee /proc/sys/net/ipv4/ip_forward

use your system interface info

Cloud 9 → VSCode port 3000

VSCode on these devices is still a work in progress, the ide works with extensions.

To enable, as it’s pre-installed, but not actually running:

sudo systemctl enable --now bb-code-server


Thanks for the reply. Gotta say that whoever made the call to start shipping with the “IoT” image did so poorly as it invalidates all the Getting Started documentation, destroying the out of box experience in the process. Spent a few hours trying to figure out if I was doing something wrong. A simple revision to the docs adding this note would have been appreciated. Rant off.

Current docs are here… BeagleBoard Documentation — BeagleBoard Documentation

Cloud9 was bought by Amazon, and closed up/abandoned. VSCode is a nice resource hog… sadly xfce + VScode + nodered no longer even fits on the 4gb eMMC. Even with the iot image it’s a struggle once swap is enabled to make VSCode decent.

Id love to find another option, but VSCode has really taken over…

Have you tried CLion from jetbrains. I do remote builds, once configured just select the profile and everything needed is downloaded to the target, built, then executed. Typically do the majority on local then spot check on the target occasionally. Obviously if you need resources like I2C that are not on the local box that does not work however that does not prevent build/run on the target. No messing around with cross-compiles.

My preference is netbeans, however the C/C++ module has some annoying issues that might not get fixed. It is still in the old java 8 store and java 8 is finished on debian. So been trying other things out and CLion is about the closest to what I need.

1 Like

Looks neat, 30 day license key… won’t be able to distribute…

Another one I’ve looked at in the past is theia… Theia - Cloud and Desktop IDE Platform now that Arduino ships it, might be worth it again.

Robert, I think you’re missing my point. Please listen.

  • A first time user buys a BeagleBone Black.
  • The printed instructions in the box say “Follow these steps…”
  • The user follows those steps - the result is not as is shown in the instructions.
  • So the user thinks, “Maybe there’s been an update.” and goes on-line to check.
  • Lo and behold, the same instructions are there too. So the user follows them once more and sure enough, the results do not match.
  • So the user digs deeper and finds this page, and follows those instructions which once more do not produce the results shown (and after having to debug those instructions because they are wrong when connecting to a Mac or to a Linux box).
  • Not to be deterred, the user tries with multiple machines, multiple connection methods (“stand-alone”, via USB, via ssh), multiple browsers and all produce the same incorrect response.
  • By now the user has spent a few wasted hours in complete frustration with a product that “From kindergarten to Kickstarter, the BeagleBone Black will get you started programming electronics within minutes of opening the box.”

Maybe there are technical reasons for a change as you state, but that is 100% the wrong answer because none of the documentation has been updated to reflect it and there is no way a new user could know that… And all you had to do was put a note on the screen during boot that said something to the effect of "Things have changed, see the revised ‘Getting Started’ guide at… " and give the new URL.

Someone dropped the ball big time. It’d be nice if someone addressed this significant issue.

Yes, however they don’t seem to be following big tech ethos. When you do buy a “subscription” the license will fall back to perpetual license if you don’t renew it. That is what got me to even consider using the product.

They do offer programs for students and support open source projects.

I had a couple of small newbie issues and the person that helped me out on their forum is an employee and was spot on.

I feel it would be a good joint venture for BB and JB.

If you decide to try it use the .gz from the JB site, apt package is old and does not have the remote build tools.

Also, when you reach out to them mention how BBB has a strong support in Yocto. Plus the fact that BBB is an extremely powerful learning tool.

That works hand-in-hand with the “code-with-me” package. I have not personally tried it out, however that is an extremely powerful tool for education.

1 Like