Beaglebone Blue Wifi Issue with Re-flashed Image

Just flashed bone-eMMC-flasher-debian-10.3-iot-armhf-2020-04-06-4gb.img to my Beaglebone Blue, and everything looks OK except that when I scan for Wifi networks, I get nothing.

Where I’m at:

  1. Boot board and connect via USB
  2. open terminal window
  3. start connmanctl
  4. scan wifi
  5. services

Now, the problem is that I don’t get anything in the services - not a jot. It worked when I first got the board, but since re-flashing the board it doesn’t.

Would appreciate any help.

@DirtFarmer please re-test with:

ps, ssh key generation will take a while, so WiFi/connmanctl won’t actually work for atleast the first minute or two after “first” bootup after flashing…


connmanctl> tether wifi disable
Error disabling wifi tethering: Already disabled
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
    duinotech-17f312     wifi_38d269e0044f_6475696e6f746563682d313766333132_managed_none
    WiFi-2BAC            wifi_38d269e0044f_576946692d32424143_managed_psk
    Living Room TV.b     wifi_38d269e0044f_4c6976696e6720526f6f6d2054562e62_managed_none
    Optus_6AB83E         wifi_38d269e0044f_4f707475735f364142383345_managed_psk
    Ashfield             wifi_38d269e0044f_4173686669656c64_managed_psk
    Aussie Broadband 8561 wifi_38d269e0044f_4175737369652042726f616462616e642038353631_managed_psk
    Belong1AEDC2         wifi_38d269e0044f_42656c6f6e67314145444332_managed_psk
    eufy RoboVac 35C-FAD9 wifi_38d269e0044f_6575667920526f626f566163203335432d46414439_managed_none
    Loft speaker.o       wifi_38d269e0044f_4c6f667420737065616b65722e6f_managed_none
    TelstraBC0B49        wifi_38d269e0044f_54656c73747261424330423439_managed_psk
    Fon WiFi             wifi_38d269e0044f_466f6e2057694669_managed_none
    Telstra Air          wifi_38d269e0044f_54656c7374726120416972_managed_none
    Telstra0E30          wifi_38d269e0044f_54656c7374726130453330_managed_psk
connmanctl> connect wifi_38wifi_38d269e0044f_576946692d32424143_managed_psk
Error /net/connman/service/wifi_38wifi_38d269e0044f_576946692d32424143_managed_psk: Method "Connect" with signature "" on interface "net.connman.Service" doesn't exist

Oh, and I’ve connected a 12V supply as well in order to eliminate any potential power issues from the USB.

Thanks @RobertCNelson. I flashed that image to the board, still getting similar results. The only difference now is:

After first booting the board, I do get networks when entering services.
Then after trying to connect to my network, nothing - I get an error and the list is empty again.

What am I doing wrong??

i doubt it’s this: (add agent on)

agent on
connect wifi_........

What does the script print out?

sudo /opt/scripts/tools/


dogtag:[ Debian Buster IoT Image 2021-09-01]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2019.04-g1da4564 (Aug 31 2021 - 14:32:40 +0000)]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2019.04-g1da4564]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-boneblue.dts]
UBOOT: Loaded Overlay:[AM335X-PRU-RPROC-4-19-TI-00A0]
UBOOT: Loaded Overlay:[]
/boot/uEnv.txt Settings:
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal input bluetooth netdev gpio admin tisdk weston-launch cloud9ide]
cmdline:[console=ttyS0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[ 16.469808] remoteproc remoteproc0: is available
[ 16.483292] remoteproc remoteproc1: is available
[ 60.623768] remoteproc remoteproc2: wkup_m3 is available
[ 61.172152] remoteproc remoteproc2: powering up wkup_m3
[ 61.172186] remoteproc remoteproc2: Booting fw image am335x-pm-firmware.elf, size 217148
[ 61.172473] remoteproc remoteproc2: remote processor wkup_m3 is now up
dmesg | grep pru
[ 16.469808] remoteproc remoteproc0: is available
[ 16.469989] pru-rproc PRU rproc node pru@4a334000 probed successfully
[ 16.483292] remoteproc remoteproc1: is available
[ 16.483495] pru-rproc PRU rproc node pru@4a338000 probed successfully
dmesg | grep pinctrl-single
[ 0.951428] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

@RobertCNelson Many thanks for your help, it’s much appreciated.

I’ve spent quite some time trying to get this working, and in the end I tried the image bone-eMMC-flasher-debian-10.10-iot-armhf-2021-07-09-4gb.img from /rootfs/ And that worked <great success!>

The only thing I’m wondering about is why the later images don’t do wifi so well.

Again, many thanks.