BeagleBone boot problem

I have a booting problem with my BeagleBone.

I am running the Angstrom image (Angstrom-Cloud9-IDE-eglibc-ipk-
v2012.01-core-beaglebone-2012.01.11.img.gz).

When I was playing with it, suddenly it hung (does not respond to
input to /dev/ttyUSB1).
I pressed reset button, nothing happened.
I eject the SD-card, and re-pressed reset button, hoping for CCCC in
terminal screen, but it still did not respond.
I have also tried power cycling the board (unplug then plug the USB
cable), and using external power supply, with the same result.

Because I don't see the CCCC, I think the boot ROM code does not
execute, so maybe it is power/clock sequencing problem?

Has anybody ever encountered this issue?

Regards,

It's been a while.
Anyone has idea of what was happening?

Regards,

Any chance that you can tell us which board you have? It will help us in trying to answer your question.

Gerald

As I think about it, do you have anything plugged into the expansion headers?

Gerald

I have Rev A3 board, with S/N 5011BB001002.

No, nothing is plugged into the headers.
This issue occurs very infrequently. Up to now I have only experienced
it three times, so I am still unable to get a means to reproduce it.
I think, any pointers should be useful (check reset pin voltage, R,
etc.)

Thanks.

Check the voltage on the reset pin on the expansion header.

Gerald

Do you mean SYS_RESETn located in P9 header pin 10?
Okay, I'll check it when the issue re-appears.

A question, is there any way to verify that the clock is running
properly?

Thank you.

Yes. Go ahead and check it now.

As to the clock, it is a crystal, so if you put a scope on it it might stop. Otherwise you can just put a scope on the crystal and check the frequency. It will not be 500 or 720MHz as that is all controlled internal to the processor.

Gerald

I have not encountered the issue again, the board is still running by
now.
I checked the SYS_RESETn pin, it is 3.265 V.

Next time I encounter the issue, I'll check the pin again and report
here.

Except power, clock, and reset, is there any other factor that can
prevent the chip from booting?

Thank you very much, Gerald.
Regards,

The only other thing is if the processor is having trouble reading the SD card but if that were the case, it would most likely never boot.

Gerald

Are you plugged into adequate power?

I believe I supplied adequate power, as I have tried both with USB-
only power and external 5V power supply.
I did not check the voltages, though.