BeagleBone: Bringing back default (bone101) webserver after opgk update/upgrade

Got BeagleBone, ran opkg update then opkg upgrade, then copied over new uImage as detailed in a previous e-mail.

However, on boot now, I don't get the normal bone101 webpage on port 80. Instead I get a "Error 404: 'index.html' Not Found" returned in my browser.

If I try to manually run the Cloud9 server.js, Cloud9 says "warn - error raised: Error: EADDRINUSE, Address already in use".

So what are the magic commands to restore the ability to let the Cloud9 server run and serve up bone101?



cd /var/lib/cloud9
git pull

then tell me what happens. i think some images have a bad bonescript, so it might not pull.

if it fails, try

opkg update
opkg install bonescript

again, tell me what happens. i am not sure that is the right package name or if the updated version is in the feed yet, but i’ll look up the info if it doesn’t work for you.

Thanks Jason.

root@beaglebone:/var/lib/cloud9# git pull

remote: Counting objects: 23, done.

remote: Compressing objects: 100% (11/11), done.

remote: Total 17 (delta 12), reused 11 (delta 6)

Unpacking objects: 100% (17/17), done.

From git://

8898f4e…4dc6ae5 master → origin/master

Updating 8898f4e…4dc6ae5


bone101/index.html | 2 ±

bonescript/eeprom.js | 8 +±-

bonescript/test-eeproms.json | 88 ++++++++++++++++++++++++++++++++++++++++++

3 files changed, 93 insertions(+), 5 deletions(-)


and that solved the problem! Thanks so much-


Hey Jason Im having more or less the same problem. It seemed like the bone101 page only ran the first time I booted it up. Without having yet run opkg update I was unable to browse to beaglebone.local on port 80. Im able to get to cloud 9 on port 3000 ok but nothing on 80.

I tried the steps mentioned above… no change.

Is this different than your other similar thread?