BeagleBone doesn't boot

I had a Beagle Bone sitting in a drawer for some time and after a few months I decided to pull it out again and do something with it, but I have a problem: it doesn’t boot with the latest official image ( I downloaded.

I’m running on a Mac and I’m powering from a UBS port. What I see is that the power led is on, but then the other USR0* LEDs do not start lighting up.
Also, no external drive shows up on the Mac, but in the network interfaces 3 new interefaces appeared: SUBARCTIC (and SUBARCTIC 2 and 3), the first one appearing as ethernet connection and the other 2 as modems.
The first one is active, and has got a IP address ( from a DHCP server, which is totally different from the one shown in the docs
Also connecting with “screen” doesn’t help

I tried resetting the board with button several times, but nothing changed.

I also tried with an older image I had, and it boots (even tho the SUBARCTIC interface doesn’t get enabled, even after unmounting the disk and only way to connect to device is either via screen or to plug in an ethernet cable).

Has anyone an idea of what might be the problem and how to solve it? it would also be helpful to solve the other problem I have with the “old” version of the OS?

Thank you

Is this a BeagleBone or a BeagleBone Black?


Beagle bone r5

Go to the support Wiki and download the production version that ships with the board. Makes sure that works before you try any newer images that are intended mainly for the BeagleBone Black, but are supposed to work on your board…


that works, as I wrote already, except that I cannot get the USB-ethernet to work but only by plugging in an ethernet cable… and also not the 192.xxxx address but only a address


So the board is fine. The question then is the operation of the board with the much newer image.


Hi everyone,

I have removed the MLO file from eMMC (to force to boot from microSD) and my Beaglebone Black no longer boot!

I have followed the following link:

Is there an easy way to restore the MLO file back on eMMC?

Please help!!!


OK. Let me try this again.

Do what it says at the above link. This will put the MLO back on the eMMC. You just can’t copy manually from an SD card, It has to go in the exact location.

Follow the procedure exactly as written.



Dear Gerald,

Thank you so much for the below link, I will follow the procedure and keep you posted.


Similar for me, I just brought it out after not touching it for months updated to the latest


And now it’s a brick. I have a A6a, the power light comes up but none of the user led lites up.

I did the hold the reset as you plug it in and waited for 45 seconds but nothing ever happens.

my Mac doesn’t see the beagle bone in the Finder but my Mac does hang for 5 seconds when I hit the reset.

The BeagleBone has no flash. It always boots from the SD card. make sure you use the version that allows you to boot from the SD card. You can’t brick the board unless you can’t find an SD card that it can boot from.