[Beaglebone] Driver for TLV320AIC3xx in Robert Nelsons kernel...installation...

Hi,

from Rober Nelsons linux-dev and linux-stable sources I successfully build a kernel, which
boots fine into the desktop of the Beaglebone.

With the source tree there comes a script, which installs the kernel and the modules on
the already prepared SD-card.

Before the installation /boot looks like this:

drwxr-xr-x 4 root root 4096 2012-05-16 15:29 Docs
drwxr-xr-x 5 root root 4096 2012-05-16 15:29 Drivers
-rwxr-xr-x 1 root root 5829 2012-05-16 06:48 LICENSE.txt
-rwxr-xr-x 1 root root 37151 2012-05-08 08:16 MLO
-rwxr-xr-x 1 root root 13901 2012-05-16 06:48 README.htm
-rwxr-xr-x 1 root root 178 2012-05-16 06:48 autorun.inf
-rwxr-xr-x 1 root root 171 2012-05-16 06:48 info.txt
-rwxr-xr-x 1 root root 524288 2012-06-18 11:04 test-file
-rwxr-xr-x 1 root root 239744 2012-05-08 08:16 u-boot.img
-rwxr-xr-x 1 root root 33 2012-05-08 08:16 uEnv.txt
-rwxr-xr-x 1 root root 3179944 2012-05-08 08:16 uImage

The contents of the /boot directory is now after running the installatino script:

-rwxr-xr-x 1 root root 33 Aug 10 08:14 uEnv.txt
lrwxrwxrwx 1 root root 13 Aug 16 04:13 uImage -> uImage-3.2.25
-rw-r--r-- 1 root root 3182864 May 22 13:15 uImage-3.2.16
-rw-r--r-- 1 root root 3083432 Jun 14 21:31 uImage-3.2.18
-rw-r--r-- 1 root root 3317824 Jul 14 14:07 uImage-3.2.21
-rw-r--r-- 1 root root 3319440 Aug 6 10:10 uImage-3.2.25

The /lib/modules directory before the installation:

drwxr-xr-x 3 root root 4096 2012-08-16 06:13 3.2.18
drwxr-xr-x 3 root root 4096 2012-08-16 06:13 3.2.21
drwxr-xr-x 3 root root 4096 2012-08-16 06:13 3.2.25

and after the installation:

drwxr-xr-x 3 root root 4096 Aug 16 04:13 3.2.18
drwxr-xr-x 3 root root 4096 Aug 16 04:13 3.2.21
drwxr-xr-x 3 root root 4096 Aug 16 04:13 3.2.25
drwxr-xr-x 3 1001 users 4096 Aug 8 19:10 3.2.25-psp20

I attached the Chipsee Multimedia Cape to my beaglebone, which
includes (beside other things) a TLV320AIC3106IRGZ (TI).

The according module is here:

/lib/modules/3.2.25-psp20/kernel/sound/soc/codecs/snd-soc-tlv320aic3x.ko

After booting the bone, the driver is not loaded.

modprobe -a snd-soc-tlv320aic3x does not find the module.

Ergo: The directory 3.2.25-psp20 is not seen/used by the current setup.

How can I activate the wanted driver?

Thank you very much in advance for any help!
Best regards,
mcc