Beaglebone drivers would not load on windows8 machine

Hi All,

I had trouble getting my windows8 pc to upload beaglebone drivers.

The problem is all new window8 pcs are automatically set to not allow installation of unsigned drivers.

Here is the fix

  1. Press win+c on the keyboard to bring up the charms side bar (or move mouse to right top corner of the screen)

  2. Click the Settings button.

  3. Click the Change PC Settings at the bottom of the sidebar.

  4. On screen that shows up, select the General option from the sidebar then scroll down the page that appears.

  5. Click the Restart now button under the Advanced startup section.

  6. You will momentarily see the restarting screen, then it will switch to a blue screen titled “Choose an option”

  7. Click the Troubleshoot button.

  8. Click Advanced options.

  9. Click Startup Settings

  10. Click Restart

  11. You should then see a Startup Settings screen after your computer reboots.

  12. Press 7 or F7 on your keyboard to Disable driver signature enforcement

  13. Now Windows 8 will continue starting up.

  14. Log-in as normal, and then run BONE_D64.exe again

  15. Now you should see 4 warning dialogs about “unsigned driver installation”, click OK for all of them.