Beaglebone ethernet don't work

ok, will send it tomorrow

Thank you!


Make sure you request the RMA before you send the board in.


My board (which arrived last week) worked fine, until I performed an
'opkg upgrade'. Now I am in the same boat with this ethernet issue. A
little frustrating to be sure as I'd read this thread, and didn't
connect the dots that maybe it was related to newer software. I am
going to rescue some python code from the microsd card and attempt to
wipe the filesystem with an earlier image, and see if I can get back
to ground 0. Will report back with any success (or failure).


Quick followup, it was too early/late... my issue was different than
the topic of this discussion. I was able to bring the network up with
an ifconfig eth0 up, and a new image fixed the issue. Sorry for the


I too, lost the ethernet port with the 'opkg upgrade'. So I carefully installed what I needed. I also tried to get a mySql 5 server running and found that the ssh process was being killed off for some reason.

I had to format and build the images on the micro SD card to get it back. I used 'nmap' running on another box to check whether the ssh process was running. Often it was not.



Are there any news regarding the issue with the PHY on BeagleBone

It seems that I also have the same problem. The PHY drops the link
after power-up.
If I unplug the Ethernet cable then the yellow led starts flashing and
finally comes up, but it drops soon when I plug the cable.
The PHY chip is quite warm touching by hand. (The CPU and the FTDI
also warm, at least if I compare them to the OMAP3 on BeagleBoard C2
same 500MHz clock.)

I have the following messages in dmesg:
[ 0.300345] davinci_mdio davinci_mdio.0: davinci mdio revision 1.6
[ 0.300365] davinci_mdio davinci_mdio.0: no live phy, scanning all
[ 0.300565] davinci_mdio: probe of davinci_mdio.0 failed with error
[ 4.789170] PHY 0:00 not found
[ 4.792500] PHY 0:01 not found
[ 1088.508603] PHY 0:00 not found
[ 1088.511963] PHY 0:01 not found

I have tried both the Angstrom sdcard and the Agora one from TI.
Actually the link drops before the kernel starts. I tried to stop the
boot process and see what can I do wit u-boot, but no success. Link

Can it be a problem with u-boot? Have anyone tried to compile a new

Thanks for any update in advance.

Best regards,

We are looking into the issue. We have only been able to look at one board so far and that appears to be a manufacturing issue. We received two more boards yesterday that we are looking into now. So nothing new to report.

I suggest that you request an RMA so that we can look at your board as well. We only have about 8 cases like this out of the 5000 boards we have shipped and it is tough to debug a board via emails.

I will say this, the yellow LED i supposed to turn off if you have a 100M link. That is normal and not an indication of wether or or not the link is up.


same problem here, the first BeagleBone would sometimes boot up
correctly or just print 'CCCC' characters out of minicom so I sent it
back with an RMA. The new replacement BeagleBone boots correctly but
has eth0 problems :-

version 11_16_11

[ 12.850803] CPSW phy found : id is : 0x7c0f1
[ 12.857617] PHY 0:01 not found

root@beaglebone:~# ifup eth0
udhcpc (v1.18.5) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing

Linux SDK v5.03

[ 1.162396] Detected MACID=d4:94:a1:93:1b:2f
[ 1.167858] omap_rtc omap_rtc: setting system clock to 2000-01-01
00:00:00 UTC (946684800)
[ 1.179959]
[ 1.179968] CPSW phy found : id is : 0x7c0f1
[ 1.186853] PHY 0:01 not found
[ 1.271659] mmc0: host does not support reading read-only switch.
assuming write-enable.
[ 1.282753] mmc0: new high speed SDHC card at address 1234
[ 1.289104] mmcblk0: mmc0:1234 SA04G 3.63 GiB
[ 1.296260] mmcblk0: p1 p2 p3
[ 4.171153] PHY: 0:00 - Link is Up - 100/Full
[ 4.210585] Sending DHCP requests ...... timed out!
[ 81.032608] IP-Config: Reopening network devices...
[ 81.040383]
[ 81.040389] CPSW phy found : id is : 0x7c0f1
[ 81.047283] PHY 0:01 not found
[ 83.031292] PHY: 0:00 - Link is Up - 100/Full
[ 83.050653] Sending DHCP requests .....
Sending discover...
[ 176.591336] PHY: 0:00 - Link is Up - 100/Full
Sending discover...
Sending discover...
No lease, forking to background

Is there anything I can do, bearing in mind both my Pandaboard &
BeagleBoard work fine with the same power supply, usb cable & network
cable ??

Remove R219. We have been discussing this extensively on the mailing list and right now that is the easiest solution.


Hi Gerald,

I just got an A3 (from Arrow Electronics) that’s also reporting:

[ 6.992879] PHY 0:00 not found

[ 6.996122] PHY 0:01 not found

It was working at first but over time, the PHY stayed up for shorter and shorter periods of time. Now it won’t connect at all.

I’m in Dallas, Texas, not too far from TI headquarters. Would you like to examine my board, or would you like me to RMA it through Arrow?



Ooh, you’re good! Removing the reset switch worked perfectly.


I am sorry to hear that. Not that I am unhappy that you are up and running, but that it took removing a switch to fix it!