Beaglebone ethernet don't work

HI,

Are there any news regarding the issue with the PHY on BeagleBone rev:A3?

It seems that I also have the same problem. The PHY drops the link right
after power-up.
If I unplug the ethernet cable then the yellow led starts flashing and
finally comes up, but it drops soon when I plug the cable.
The PHY chip is quiet warm touching by hand. (The CPU and the FTDI chip
also warm, et least if I compare them to the OMAP3 on BeagleBoard C2 at
same 500MHz clock.)

I have the following messages in dmesg:
[ 0.300345] davinci_mdio davinci_mdio.0: davinci mdio revision 1.6
[ 0.300365] davinci_mdio davinci_mdio.0: no live phy, scanning all
[ 0.300565] davinci_mdio: probe of davinci_mdio.0 failed with error -5
[ 4.789170] PHY 0:00 not found
[ 4.792500] PHY 0:01 not found
[ 1088.508603] PHY 0:00 not found
[ 1088.511963] PHY 0:01 not found

I have tried both the Angstrom sdcard and the Agora one from TI.
Actually the link drops befor the kernel starts. I tried to stop the
boot process and see what can I do wit u-boot, but no success. Link was
dropped.

Can it be a problem with u-boot? Have anyone tried to compile a new one?

Thanks for any update in advance.

Best regards,
Blaise

We have only looked at one board so far and that appears to be a reset issue having something to d with assembly. Two more came in today, so we are looking at those now. So, we basically have very little to go on. I suggest you request an RMA and get this board to us.

Gerald
.

Hi Gerald,

Thanks for your kind answer.
Meanwhile I have found an other thread where a sw issue was causing
similar problems.
So I have created an sd-card with Ubuntu distro and it worked fine for
a while, but unfortunately it seems that after several hours the link
was dropped.
So it seems that the Ethernet can be brought up by the kernel, (for me
u-boot do not brings it up, so the config suggested by the TI document
to use TFTP and NFS to boot the board does not work.)
Unfortunately after a while the link is dropped by some reason.
I have seen this problem with the TI's Arago distro and now with the
Ubuntu 11.10 as well.

Can you suggest me a solution how can I get the serial console
working when the board is powered from an external power supply? I
tried to plug the USB cable when the board was up and running, but I
did not get anything in the terminal. It works fine if the board is
powered from USB.
Without the console I have no chance to see the logs when the link
goes down.

Thanks for your kind help in advance.

Best regards,
Blaise

PS: Thanks for your suggestion, but I would not like to request for an
RMA until I'm not sure that it is really a hardware issue.

There is no easy way to get a serial terminal without the USB port being connected. You might be able to access one of the UARTs on the expansion header and reconfigure your SW to use that port as the serial port. When the USB port and DC power is connected, you are running from the external supply. If the board goes down when run off the external DC, then having the USB connected should prevent it from going down and give you the same results as powering it just from USB as it ould switchover. You might try that and see what results you get.

Gerald

I will try to RMA my rev A3 board. I have the same problem. The
ethernet port drops intermittently. Sometimes it only runs an hour
without dropping, however right now I'm up to >48h without a drop. It
is very unpredictable and may be hard to debug, but I'm going to send
it in anyway because it is not really reliable enough for me to use in
my application.

Also, the severity of the problem seems to vary. For instance,
sometimes it drops and a couple of reboots fixes it. However, once it
dropped and Ubuntu would hang at different points during boot. This
went on for a couple of hours and finally it just booted up. After a
bunch of reboots, the ethernet port flickered for a while as though it
was not receiving correct power, then finally it just came back up
after a few more reboots. Definitely seems like a hardware issue.

Question: has this issue been reported at all on rev A4 boards or do
you think it has been fixed?

Thanks

Rev A4 was released before this issue was identified. If you can find a way to measure the reset pin on the expansion header, that may indicate your issue. If it is less that 1.7V, that is most likely your issue. It should be around 3.28V. This is causeed by a bad reset switch that has a low impedance path causing a voltage divider instead of it being open. This will make the reset voltage hover around the reset threshold for the for the PHY.

Gerald

Now you guys got me nervous. I have A3 BeagleBone too. Haven't
noticed anything strange with it but I haven't had time to really do a
whole lot with it yet either. I've run the Angstrom distro that came
on the SD Card 11_16_11 but haven't tried anything newer.

Regards,

Brian

Just check the voltage level. If there is an issue there, we will repair the board. If you do not have the symptoms, then there is a good chance that you do not have this issue… This issue is not on all 5,000 boards that we have shipped. To date, we have seen it via RMA on three boards.

Gerald

Thanks Gerald! Good to know the Father of Beagle is watching over us.

LOL! Well, as they say, what doesn’t kill you makes you stronger!

Gerald

Hi Gearld,

I just requested an RMA yesterday and this mornig I see your message
about the faulty reset switch.
I have measured the resistance of the switch when the board was
powered down and it is about 40K.
Then I connected my DVM to the reset pin and powered the board. The
voltage was about 2.2-2.4 V.
After a while (2-3 minutes) it suddenly dropped below 1.5 V. The
Ethernet connect went down and the board started to reboot suddenly.

May I remove/replace that switch myself and if it solves my problem
then cancel the RMA request?
To be honest if the whole issue is just caused by a faulty switch it
is much faster to replace it then send it back.

Thanks for your kind support.

Best regards,
Blaise

Hi,

I just received a Rev A4 board today and seems to have the same problem.

I have the following message with dmesg :
[ 1756.986125] PHY: 0:00 - Link is Up - 100/Full
[ 1756.986340] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1767.655498] eth0: no IPv6 routers present
[ 2251.235953]
[ 2251.235963] CPSW phy found : id is : 0x7c0f1
[ 2251.242778] PHY 0:01 not found
[ 2251.248236] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 2253.236233] PHY: 0:00 - Link is Up - 100/Full
[ 2253.236464] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

I have check the voltage between the reset pin (P9-10) and the P9-1 (gnd) : 3.2 v.
The board is powered via USB.

What can I check more ?

Regards

Laurent

You can remove it, but go ahead and let them know that you need a new switch and they will mail you one…

Gerald

Type “reboot” and let the board reboot and it will work. If you type “reboot” again it will not work. This is a SW issue. A work around is to remove R219.

Gerald

I just removed the switch on Chip’s board (the one we feared had been killed by tinshort). It fixed it up good as new. Well, except for the missing reset button. That’s ok though, it was small and hard to press anyway.

Steve

LOL! I guess you have big fingers! You can request an RMA and they will send you a replacement.

Gerald

I try to reboot but it still don't work.
To test the network, I use iconfig, udhcpc and try to set manually IP
address.
Is there other tools I can use ?
dmesg still show the message : "PHY 0:01 not found ".

I'm not a soldering expert ... and don't want to destroy the board by
removing the R219.
R219 is very little for my "thick" fingers :wink:
Is there another option ?

Regards,

Laurent

There is no PHY 0:01 on the board. There are two controllers in the chip and that is the second one that is not connected to a PHY.

At this point the other option is to request and RMA and send it in and they can remove it. An icepick works very well for popping it off. It won’t hurt the board.

Gerald

I have seen on your wiki that removing the R219 will not avoid the
waranty : http://circuitco.com/support/index.php?title=BeagleBone#Known_Issues
Then I remove it ... and it's easier than I thought !

Now it's seems to work (2 hours without issues).

Thanks for your Help.

Laurent

Glad it worked for you! We are putting together a video for others to try. We are moving to Rev A5 which removes the resistor so future shipments should be fine.

Gerald