BeagleBone hardware?-problem after day one

Hello,

all went well for my BeagleBone on the first day: I updated to the latest demo image [1], updated, configured and rebooted several times while beeing on USB-power, later with an 5v AC adapter connected.

Then I decided to keep the BeagleBone run over night without a USB connection, just on the 5v power supply.

So for today I wanted to add an USB wifi adapter, but beaglebone went away over night, only the PWR led was on.

After attaching the serial/usb-console and pushing reset, it just randomly boots, sometimes crashes while booting, sometimes crashes after booting correctly into Angstrom. Sometimes it won't boot at all. I've put logs of the usb-tty output on gist [2].

Also the orange ethernet LED stays on, after adding power to the board (usb or external). Sometimes it starts flickering later without having an ethernet cable connected or even booting beyond U-Boot. In the rare case of a successful boot, I was able to see messages like

"PHY 0:00 not found "
"PHY 0:01 not found "

So I'm helpless now. I'm not sure what happend, maybe the SD card was accidentially ejected by me while beeing powered, but besides that the BeagleBone just lay on a wooden cupboard all the night [3].

What should I do, what can I try?

best regards,
Roland

[1] http://dominion.thruhere.net/koen/angstrom/beaglebone/Angstrom-Cloud9-IDE-eglibc-ipk-v2011.12-core-beaglebone-2011.12.13.img.gz
[2] https://gist.github.com/1488243
[3] http://www.flickr.com/photos/rmoriz/6518300031

I had the same problem except mine lasted a week. It's on its way
back for repair/replacement.

I guess you both tried reinitializing the microSD card?

yes, several times with different versions of the demo card.

Also, the led-thing appears right after power-on, even when no sd-card is plugged in.

I have now trashed several cards through my experimenting with the bone that I went out and bought a slew of 4GB cards for less than $6 each. I am keeping a virgin copy of each OS for comparison sake.

If you think your card might be bad, I strongly recomend using Gparted under Linux to remove the partitions and rebuild them from scratch. A windows reformat is not going to take care of the problem.

Yep. Didn't make a difference.

update:

this gets interesting or even more random:

1. I went directly into U-Boot (usb (tty+power), eth, sd-card) while the eth-phy LED still was orange all the time.

2. I started "mtest" on the U-Boot cmd and a couple of minutes later, the orange eth-phy went off, the green eth-led went on. No errors found but I stopped (ctrl+c) after ~15-20 minutes.

3. then I typed "boot", which worked: I was able to login again.

log:
...
   [ 4.550253] CPSW phy found : id is : 0x7c0f1
   [ 4.557200] PHY 0:01 not found
...

4. eth0-networking works!

BUT:

When eth-cable is removed, orange led turns on again and stays on all the time. even after "shutdown -h now", power-cycle, another "mtest" in U-Boot.

Is there a way to "mtest"/reset the eth-PHY?

Anyway:

System + eth0 seem to be stable for ~30-45minutes now. Added external power and an old zd1211 wifi-usb-stick, works so far.

regards
Roland

Is U-Boot on the SD card or in firmware? I was sometimes seeing where
U-Boot wasn't able to completely load: