BeagleBone in your pocket demo

Happy to see you bought them and eager to see your Bone Tin with charger and WiFi dongle.

Well, still on wireless on the Bone. It works on the -xM, but not the Bone.

Back to my original request. Could someone compile the drivers[1] for me under v3.1 of the kernel? That driver is working on my -xM running under 2.6.32.


[1] [1] ftp://WebUser:Lc9FuH5r@[1]

Why not use the builtin drivers from the kernel?

I’ve tried, but they don’t appear to be working. I’m using the same /etc/network/interfaces file and /etc/wpa_supplicant.conf (documented in an earlier post) and I’m not able to connect.

I’m open for suggestions as to how to get the builtin drivers working.

Do you have any ideas where to look next?


First, check to see if the device was even located by the kernel.
Look at the boot messages (dmesg) to see if it's found.
You can also look at /proc/net/dev to see if it got configured
as a network interface (which based on you other errors, does
not seem so).

Just one thing - when you reply, please quote at least some
of what you are replying to. Not everyone reads the mailing
lists using Google's web interface, so a lot of context gets
lost and it makes it hard to follow :frowning:

That's not used in the default beaglebone install, so it has no effect at all.

What? When I received mine the first thing I did was go to
/etc/network/interfaces and give the Ethernet a static IP so what do
you mean that file has no effect in BeagleBone? I'll admit I haven't
done much with mine (still using the image that came with it) but I'm
surprised to see this comment ... did something fundamentally change
in how network devices are configured???



Ahhh, I see now:!topic/beagleboard/ErVbR3K8j2o

I could of swore it worked for me. Like I said I haven't played with mine much.

I guess the 'conman' conned us both! :slight_smile:

Yes, the default install uses connman for networking to reach the 10s boot mark. Have a look at

You can remove connman and install networkmanager or ifupdown if you want, but they are a lot slower during bootup. Connman is in the 100ms range, nm in the 2.5s range and ifupdown inbetween or worse depending on how much shellscripts you cram into ifup.d



Thanks for the lead. So the -xM’s network is different than the Bone’s.

It looks like I need to take the Bone home where I have a simpler network and can use static IP addresses.


No, if you have a recent image for xM you'll have connman as well. It's software, not hardware :slight_smile:

I’m still running the 2.6.32 kernel, so I assume I’m on recent enough. It’s too risky to switch kernels mid-class and I won’t switch unless I’m able to test everything on it.

I think this summer I’ll have time to switch to the latest kernel. Unfortunately everything has to work in class, so I can live close to the development edge as I’d like.

Well, the bell has rung, time to Beagle…


Any success in this error?
“Could not read interface wlan0 flags: No such device”

I am trying to run my N150 in a beaglebone, but still cannot make it work! any help is appreciated .