beaglebone: link for original, running linux kernel source

Hi folks,

I tried to compile the linux kernel source that came in the BeagleBone SDK using /proc/config.gz
and the toolchain from the SDK.

It failed with a pair of ‘relocation truncated to fit: R_ARM_THM_JUMP11’ errors.

However, am335x_evm_defconfig, did result in a clean compile but the kernel would not run.

What is the link to get the original, running linux kernel source ?

Thnx much,


I haven’t tried using the /proc/config.gz myself. I use the “make linux” target in the SDK top-level Makefile which builds the kernel using the arch/arm/configs/tisdk_am335x-evm_defconfig file. Can you give that a try?

Chase Maupin
Software Applications

For support:
Forums -
Wiki -

Hi Chase,

I tried what you suggested. It compiled cleanly but when I tried it, it would not run to console promt AFAIK.

How do I know…

I changed the /etc console setup to send . to /var/log/syslog and did a touch just in case.
The kernel did not write anything to /var/log/syslog.
P.S. I verified the approach using the original uImage and it worked fine.

An aside… How can a get std serial console output. ? I’ve tried several things to no avail.
(I have a USB to serial converter for Bone’s host port)

Thnx much,

Hi Chase.

Yes. I add the udev rules and ftdi_sio is being loaded but no joy so far.

I tried minicom /dev/ttyUSB0 but connecting merely show USB storage, on my host syslog/console

I’ll beat on some more… Perhaps I’ll try OpenOCD to talk to the ftdi.

Further, udev is fine for Linux but where are u-boot (and xload) messages

Serial console output should be available just after 1st UART init & not be so painful

Where is the kernel source that actually works ?


JTAG is on ttyUSB0, serial on ttyUSB1. I don't believe you can use
minicom to talk to JTAG.

Here's how I get a serial console from a Linux host:

Plug in the beaglebone by mini USB (no converter needed).
modprobe ftdi_sio vendor=0x0403 product=0xa6d0
If you used the udev rules in the README and have reloaded rules,
a symlink will be made to /dev/beaglebone-serial, which you can then use
in place of the ttyUSB device.

The devices will show up whether or not the mass-storage or ethernet
gadgets are in use.

Either screen -fn /dev/ttyUSB1 115200 (C-a esc to scroll, C-a \ to exit) or
set minicom to 115200, no hardware flow control
You won't see anything immediately, hit enter to get a login prompt.

Once logged in you can reboot and see early messages and hit a key to
enter U-Boot.
At the UBoot prompt, type help, or boot to continue booting.


Thanks very much… worked with minicom :))

(my USB0 and sequence were wrong: rmmod ftdi_sio needed 1st. cuz it was already in)

Anyway, I saw u-boot on watchdog reboot and I’m now at the u-boot prompt :))

I was right, kernel hangs at…

Booting kernel from Legacy Image at 80007fc0 …

Image Name: Linux-3.1.0-rc8
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 796360 Bytes = 777.7 KiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum … OK
Loading Kernel Image …

Then after a while watchdog reboots.

Well debug time…

Thnx again Frank & Chase