BeagleBone - microSD FAT format issue

I'm trying to follow the instructions on the CircuitCo wiki to create
a microSD card with the new "A5" release image..

I'm stuck here...
   7.Insert >=4GB SD card into the reader/writer.
   8. Run the HPFormatter tool and format the SD card for FAT. Close
the HPFormatter tool when done.

My microSD card is Transcend 8 GB, Class 6, brand new from Amazon I'm
using a new USB-microSD adapter from Special Computing

The microSD mounts correctly in Windows (win7 pro, 64bit), as "F:",
shows 7.4GB free, FAT32 formatted

There seem to be 2 versions of the HP Formatter tool in circulation -
v2.2.3 and the one linked to in the CircuitCo wiki. The v2.2.3 only
comes as a Windows interface, the older one has HP Both Windows
versions want to be used as "Run as Administrator" - that's fine -
doing that.

1) Using either version of the Windows of the HP tool, the HP
formatter won't let me format in FAT. The F: drive is selected as
"Device", that's correct, but ONLY FAT32 and NTFS are offered, no menu
option for FAT

2) The older HP Formatter has a DOS version ("HPUSBF.exe"). I finally
worked out that in Windows 7 at least you need to run this by creating
a DOS prompt by using "Run as Administrator" when select "Command
Prompt" from the Start menu (Otherwise you get a Device error)

BUT even when I do this, HP Formatter, under DOS with "Run as
Administrator" I get a message that "Volume is too big!"

   C:\DriveKey>hpusbf f:

   HP USB Disk Storage Format Tool, Version 1.00.012 (11/13/2003)
   Copyright (c) 2003 Hewlett-Packard Development Company, L.P.

   The type of the current file system is RAW.

   Are you really sure that you want to proceed with Format (Y/N)? y

   Verifying 7.42GB...
   ***ERROR*** Volume is too big!
   ***ERROR*** Failed to format the device!


How should I format my 8GB microSD card under Windows?

Is there a size limit for FAT (I read there is a 2GB partition limit
for FAT (vs FAT32))

Should I partition it first? (I have Acronis Disk Director)

It would be really good if the instructions on the Wiki could be as
clear as possible for Newbies with limited embedded experience and
without a Linux machine available

Many thanks!

I have confirmed that the newest version of HP Formatter tool has dropped support for FAT. Looks like the links were updated to a different versions than we have been using for 4 years now. We are looking for a solution here.

I think that if you format it to FAT32, it should be written over with diskimager, so this should not be an issue for use when just creating an image. It could be an issue when trying to make a bootable card where you plan to copy the files over manually.


I have recently just done this about 1 week ago (with a 4 gig card) and it worked fine using the FAT32.

Use HP formatter tool v2.0.6 version, it works properly.


Do you have a link for that? All the ones we have download 2.1.18, which BTW works fine for image preps…


You can download the tool from -


Alternate direct link -