Beaglebone networking restart

Hello All,

I am using Beaglebone black device for one of my meter reading IOT projects.

The following points are as per observation in the plant where project is implemented.

  1. The beaglebone black device reads Modbus data through RS-485 and sends it to remote cloud.
  2. The beaglebone uses wired ethernet (with static IP address) to connect with remote cloud.
  3. The issue i am facing is associated to internet connection:

a. after a certain point of time(mostly 1/2 minutes), the internet connection gets disconnected and if i run the following command

(/etc/init.d/networking restart), it starts working again for sometime and again i have to repeat the same procedure to
make it working.

b. for time being, i have applied a temporary fix with the help of crontab(restarting it after every two minutes),
but there are few services which needs continuous internet connection to work properly.

  1. The IT team in the plant has specifically asked for configuring local and global nameserver in the resolv.conf file

  2. The issue remains the same even if i configure either one of the nameservers in the resolv.conf file.

few observations:

  1. the issue is tested with the help of ping command (ping to either the global namerserver or local nameserver fails ).

  2. the issue is not observed in the laptop(tested using command prompt.)

  3. The hardware(beaglebone black) works properly in other environments.

  4. I have tried 2-3 hardwares(beaglebone black) in the same plant but the issue remains the same.

Can someone please help in highlighting what could be the reason behind this or any specific activity that i should follow to resolve this

thanks in advance.