BeagleBone not recognised by HyperTerminal or RealTerm!

The BeagleBone I ordered from Farnell a couple of days ago materialised today. To keep things simple I just used a USB connection with my laptop running Win7 x64. It seemed to load the drivers OK and I can access the Getting Started files on drive E:. However, it isn't recognised by HyperTerminal or RealTerm. I tried a USB - RS-232 adapter which uses an FTDI chip on the same port, and that is recognised OK as COM7, and works OK.

Does anyone know what I'm doing wrong?

Leon

the ftdi chip is included in the beaglebone, you can access the
console without your adapter.
I don't use windows but i think you need to load the ftdi drivers in
windows and you will have a new virtual com port when you connect the
beaglebone to the computer.
Use this port in hyperterminal to access the console.

Thanks.

I'd loaded the drivers. I only get these ports with the BeagleBone:

1
server:telnet
127.0.0.1:telnet
127.0.0.1:9876

None of them work, of course.

I just used the adapter with the FTDI chip to check that the driver on the laptop was working, it can't be used with the BeagleBone. COM7 works OK with that.

Leon

The Beablebone should show up as a different com port once installed -
it should use the next free port, maybe COM8.

Sounds like the drivers are not installed, even though you ran the
install package to install the drivers, the details in the drive
'.inf' files do not match the hardware IDs on the beaglebone

see this thread with some info and a link to updated drivers...
http://groups.google.com/group/beagleboard/browse_thread/thread/1b7b98c89cbd6c93/31dc0144cd1b1cc6#

and also this note...
"2. Any edits to the INF files will invalidate the signatures.
Windows
   XP and 32-bit versions of Windows Vista and Windows 7 will show an
   "unsigned driver" warning. It is safe to proceed through this
warning.
    64-bit Windows Vista and 7 *require* signed drivers, either
through WHQL,
   or self-signed. Until new BONE_DRV.exe and BONE_D64.exe files can
be
   generated and released, users will need to boot these 64-bit
Windows
   systems with the <F8> boot menu and select the option to disable
the signed
   driver requirement ***on EVERY reboot or power-up***. (Suspend
and
   Hibernate are OK). "
from here...
http://groups.google.com/group/beagleboard/msg/f7d949feb693d85d

BH

Thanks, BH.

I seem to be having the same problem as the OP in that thread, with two BeagleBone devices shown in the Device Manager under Other Devices that haven't installed properly.

I downloaded Jason Kridner's BONE_D64.exe file that is supposed to fix the problem:

http://groups.google.com/group/beagleboard/browse_thread/thread/1b7b98c89cbd6c93/31dc0144cd1b1cc6

but it won't install - I get an error message saying that it's not compatible with my version of Windows. It looks like there is a problem with the current version of Win7 x64.

I'll try contacting Jason.

Leon

I downloaded the BONE_D64.exe file from beagleboard.org, and that
worked! I can't log in, but that's another problem. :frowning:

Leon

I got the version that actually worked from the latest on-line version
of README.html:

http://beagleboard.org/static/beaglebone/a3/README.htm

I was trying to log in with "BeagleBone", instead of "root".