BeagleBone, Perl and CPAN

Try installing the build-essentials package (i.e. apt-get install build-essentials).

On Ubuntu, that’s a prereq for CPAN.

Dan.