Beaglebone Rev. A3: FTDI not showing

Hi folks,

I am trying to hook up my Beaglebone Rev. A3 to my Ubuntu box using a USB cable, but it does not seem to show up, either as serial, Ethernet or UMS.

Actually, it seems that the onboard USB hub is correctly detected but that all other devices (including the FTDI adapter) remain silent - see my syslog output below:

Sep 5 12:40:19 neskaya kernel: [ 8481.477495] usb 1-1.2: new high speed USB device number 7 using ehci_hcd
Sep 5 12:40:19 neskaya kernel: [ 8481.571059] hub 1-1.2:1.0: USB hub found
Sep 5 12:40:19 neskaya kernel: [ 8481.571211] hub 1-1.2:1.0: 2 ports detected

I have tried on each and every USB port on the host box, even tried on other machines but to no avail. I also tried to boot the latest Angstrom image from the micro SD card but it does not seem to do anything, except lighting up the PWR LED.
The board worked fine a few months ago when I received it. I have had to put it aside for some time because of a shift in priorities, but now that I have some time to play around, it looks like it wants to snub me :frowning:

Any idea ?
Thanks and regards.
– JB.L


How can I diagnose further ? Should I request an RMA for my board ? Is there anything I can do to assess the status of the components ?
– JB.L

2012/9/5 JB.L <>

Try going here and follow the instructions and see if that cures your issue.


Thanks for your answer, however these instructions seem to apply to a Windows host box and imply that the VID/PID of the FTDI is sent by the board. In my case, when I link the board to my Ubuntu host box, only the VID/PID of the onboard USB hub are received.

I will try with a Windows host to see if it gets any better.
– JB.L

2012/9/7 Gerald Coley <>

This is required to get the default FTDI drivers installed. Using the default on A3 will not work for sure. If it still does not work under Ubuntu, then you have other issues and then still need to install the drivers. The drivers for the A3 revision came on the SD card that shipped with it and you can install those. But this solution has shown to work on Linux, windows, and Mac using the default FTDI drivers…



I followed the instructions, using my Windows 7 64b box, but it does not change anything to the status of the board: it seems that the onboard hub is the only component seen from the host box.

Is there anything I can do to assess the health of the onboard chips (FTDI, OMAP) ? I don’t have access to an oscilloscope or logic analyzer for the moment, but I do have a multimeter.
– JB.L

2012/9/7 Gerald Coley <>