BeagleBone Rev.A3 not working

Good day,

I have a problem regarding BeagleBone. Let me explain how it happened.

After a month or so, I’ve finally got a Circuitco DVI cape, attached it to Bone and bootted the default Angstrom version that came with BB. System found the cape and the logo was on LCD. Great. The first strange thing is, that it booted from the original uSD card/image that came with BB. Because in december when I bought a BB from Farnell the same image didnt want to boot (got errors), but I didnt put to much effort into it, because I made a custom stripped-down image with php server and etc. OK, powered off the board through-out the night and in the morning tried to boot with the same default image. This time with errors. It found the capes I2C EEPROM but said there was no cape found. OK, downloaded the newer Angstrom version and again powered on the system. It booted succesfully and it worked for the whole day. During the day I’ve inserted a USB Hub with a mouse and a keyboard and surfed on the internet with Firefox on BeagleBone. The next day I’ve downloaded the new SDK version 5.04 from TI page, installed it’s kernel and boot images onto microsd card, detached DVI cape and Hub and then booted from NFS root. Everything went on fine, no errors and it booted into shell. Powered down again, this time attached the DVI cape and booted successfully again. Now the problems started … I’ve attached the same Hub with mouse and keyboard as the day before and everything went blank. BeagleBone was powered from the AC and the miniUSB was also attached for debugging purposes during this whole time. After that I tried to restart (e.g. AC/USB cable out and in again), there was no response. With every power restart, power LED blinks once, fast, and then everything is blank again. Now, I’ve tried to locate the failure and found out, that the VDD_3V3A line is somehow short-circuited to GND.

My question now is, if I remove R19 resistor to test if the failure is in TPS65217B or elsewhere on the board (presume USB HOST section), do I loose my warranty or it is best to send the board into RMA for their inspection - even so if I purchased BeagleBone more then 90 days ago?

Thank you very much for your support and have a nice day,

You can remove the resistor, but if it is determined that in the process you cause more damage to the board, then that would result in an additional charge to fix it. I would not power on the board with that resistor out.

I would recommend that you go ahead and send boht boards in on an RMA and have them looked at. Finding which rail is shorted is not going to fix the board.