Beaglebone SSH connection failing

This morning I dug out my BB rev C and uploaded the latest image (Debian 8.7 2017-03-19 4GB SD LXQT) from The flash and update suceeded and I was able to login via SSH using the default debian/temppwd after connecting it to my Win7 host computer via USB. Able to connect to via Putty with debian/temppwd

Then the trouble starts. At an interval ranging from 5 to maybe 240 seconds I get a popup saying “software caused connection abort”

I tried the same thing from within a VM running Jessie. SSH in and after a little while I get “Write failed: Broken Pipe”

I tried running putty as administrator and setting keepalive to 5 seconds but no change.

I thought it might be the power over USB but I tried it with a 5v adapter plugged in and I am still seeing the same issue.

Checked SSH by logging into a remote machine from the host and it has no issues.

Has anyone seen this sort of behaviour before? I’m also seeing connectivity issues from The notification box that goes green when my BBB is connected disappears with about the same frequency. Same when using the cloud9. The device remains available for browsing within file explorer.

Many thanks

My guess is that it has something to do with Windows and the USB widget/gadget thing.
Instead, try connecting to the BBB using Ethernet.
I run multiple BBBs as headless servers, using that same image, and access them for programming and maintenance via SSH over Ethernet.
Use either Putty, or RSE inside of Eclipse.
It is rock solid.

— Graham