BeagleBoneBlack unable to boot properly

Hi,
I am trying to run an old ubuntu14.0 OS image on my beaglebone board, which also include the ROS for my project.
Now the problem is it is not booting properly. This old ubuntu image I flashed to the memory card using win32DiskImager.
This image has only the root filesystem in it although this file system is ext4 but is *boot flagged (fdisk command told me this).
Now I am unable to run this image on my BBB but previously it was running.
here is the output of the boot process:

=> board_name=[A335BNLT] …
board_rev=[00A6] …
switch to partitions #0, OK
mmc0 is current device
SD/MMC found on device 0
** Bad device 0:2 0x82000000 **
** Bad device 0:2 0x82000000 **
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1…
gpio: pin 56 (gpio 56) value is 0
gpio: pin 55 (gpio 55) value is 0
gpio: pin 54 (gpio 54) value is 0
gpio: pin 53 (gpio 53) value is 1
switch to partitions #0, OK
mmc0 is current device
gpio: pin 54 (gpio 54) value is 1
Checking for: /uEnv.txt …
743 bytes read in 9 ms (80.1 KiB/s)
gpio: pin 55 (gpio 55) value is 1
Loaded environment from /uEnv.txt
Importing environment from mmc …
Checking if uenvcmd is set …
gpio: pin 56 (gpio 56) value is 1
Running uenvcmd …
83 bytes read in 34 ms (2 KiB/s)
5506960 bytes read in 382 ms (13.7 MiB/s)
26098 bytes read in 96 ms (264.6 KiB/s)

Flattened Device Tree blob at 88000000

Booting using the fdt blob at 0x88000000
Using Device Tree in place at 88000000, end 880095f1

Starting kernel …

Uncompressing Linux… done, booting the kernel.
[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.8.13-bone68 (bbb-dev@bbbdev-VBox) (gcc version 4.7.3 20130328 (prerelease) (crosstool-NG linaro-1.13.1-4.7-2013.04-20130415 - Linaro GCC 2013.04) ) #1 SMP Fri Dec 12 15:30:25 IST 2014
[ 0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=50c5387d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ 0.000000] Machine: Generic AM33XX (Flattened Device Tree), model: TI AM335x BeagleBone
[ 0.000000] Memory policy: ECC disabled, Data cache writeback
[ 0.000000] AM335X ES2.0 (l2cache sgx neon )
[ 0.000000] PERCPU: Embedded 9 pages/cpu @c0d11000 s14080 r8192 d14592 u36864
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 129792
[ 0.000000] Kernel command line: console=tty0 console=ttyO0,115200n8 root= rootfstype=ext4 rootwait init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v2.sh
[ 0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[ 0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] __ex_table already sorted, skipping sort
[ 0.000000] allocated 1048576 bytes of page_cgroup
[ 0.000000] please try ‘cgroup_disable=memory’ option if you don’t want memory cgroups
[ 0.000000] Memory: 511MB = 511MB total
[ 0.000000] Memory: 508396k/508396k available, 15892k reserved, 0K highmem
[ 0.000000] Virtual kernel memory layout:
[ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
[ 0.000000] vmalloc : 0xe0800000 - 0xff000000 ( 488 MB)
[ 0.000000] lowmem : 0xc0000000 - 0xe0000000 ( 512 MB)
[ 0.000000] pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
[ 0.000000] modules : 0xbf800000 - 0xbfe00000 ( 6 MB)
[ 0.000000] .text : 0xc0008000 - 0xc07c0e08 (7908 kB)
[ 0.000000] .init : 0xc07c1000 - 0xc07fe700 ( 246 kB)
[ 0.000000] .data : 0xc0800000 - 0xc0887740 ( 542 kB)
[ 0.000000] .bss : 0xc0887740 - 0xc0900ec0 ( 486 kB)
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=1.
[ 0.000000] NR_IRQS:0 nr_irqs:0 0
[ 0.000000] IRQ: Found an INTC at 0xfa200000 (revision 5.0) with 128 interrupts
[ 0.000000] Total of 128 interrupts on 1 active controller
[ 0.000000] OMAP clockevent source: GPTIMER1 at 24000000 Hz
[ 0.000000] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 178956ms
[ 0.000000] OMAP clocksource: GPTIMER2 at 24000000 Hz
[ 0.000000] Console: colour dummy device 80x30
[ 0.000000] console [tty0] enabled
[ 0.000637] Calibrating delay loop… 993.47 BogoMIPS (lpj=969728)
[ 0.029197] pid_max: default: 32768 minimum: 301
[ 0.029341] Security Framework initialized
[ 0.029406] Mount-cache hash table entries: 512
[ 0.035176] Initializing cgroup subsys cpuacct
[ 0.035219] Initializing cgroup subsys memory
[ 0.035266] Initializing cgroup subsys blkio
[ 0.035361] CPU: Testing write buffer coherency: ok
[ 0.035753] CPU0: thread -1, cpu 0, socket -1, mpidr 0
[ 0.035824] Setting up static identity map for 0x804a3db8 - 0x804a3e04
[ 0.036751] Brought up 1 CPUs
[ 0.036777] SMP: Total of 1 processors activated (993.47 BogoMIPS).
[ 0.037574] devtmpfs: initialized
[ 0.045982] omap_hwmod: wd_timer2: _wait_target_disable failed
[ 0.085778] pinctrl core: initialized pinctrl subsystem
[ 0.085967] rstctl core: initialized rstctl subsystem
[ 0.086267] regulator-dummy: no parameters
[ 0.086591] NET: Registered protocol family 16
[ 0.087131] DMA: preallocated 256 KiB pool for atomic coherent allocations
[ 0.092743] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
[ 0.093315] platform 49000000.edma: alias fck already exists
[ 0.093344] platform 49000000.edma: alias fck already exists
[ 0.093366] platform 49000000.edma: alias fck already exists
[ 0.094110] OMAP GPIO hardware version 0.1
[ 0.096580] gpio-rctrl rstctl.4: loaded OK
[ 0.099866] No ATAGs?
[ 0.099888] hw-breakpoint: debug architecture 0x4 unsupported.
[ 0.101150] cpsw.0: No hwaddr in dt. Using c8:a0:30:ac:85:ec from efuse
[ 0.101186] cpsw.1: No hwaddr in dt. Using c8:a0:30:ac:85:ee from efuse
[ 0.109381] bio: create slab at 0
[ 0.115747] edma-dma-engine edma-dma-engine.0: TI EDMA DMA engine driver
[ 0.116045] vmmcsd_fixed: 3300 mV
[ 0.117608] SCSI subsystem initialized
[ 0.117869] usbcore: registered new interface driver usbfs
[ 0.117942] usbcore: registered new interface driver hub
[ 0.118156] usbcore: registered new device driver usb
[ 0.119404] omap_i2c 44e0b000.i2c: bus 0 rev0.11 at 400 kHz
[ 0.120324] input: tps65217_pwr_but as /devices/ocp.3/44e0b000.i2c/i2c-0/0-0024/input/input0
[ 0.121968] DCDC1: at 1500 mV
[ 0.122817] vdd_mpu: 925 <–> 1325 mV at 1325 mV
[ 0.123645] vdd_core: 925 <–> 1150 mV at 1100 mV
[ 0.124456] LDO1: at 1800 mV
[ 0.125289] LDO2: at 3300 mV
[ 0.126776] LDO3: 1800 mV
[ 0.127593] LDO4: at 3300 mV
[ 0.128308] tps65217 0-0024: TPS65217 ID 0xe version 1.2
[ 0.128774] omap_i2c 44e0b000.i2c: unable to select pin group
[ 0.129304] omap_i2c 4819c000.i2c: bus 1 rev0.11 at 100 kHz
[ 0.130681] omap_i2c 4819c000.i2c: unable to select pin group
[ 0.130909] media: Linux media interface: v0.10
[ 0.130986] Linux video capture interface: v2.00
[ 0.131064] pps_core: LinuxPPS API ver. 1 registered

Hi,

If you change the rootfs to some other version of Ubuntu will it work?

Regards,
Madhu

I only want to run an older image which had no uboot.img and MLO file only the vmlinuz-3.18 kernel. And that image used to run before.I don’t know why its not running now

Fix your /uEnv.txt

your passing:

root=
&
init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v2.sh

so your not passing the root-partition information and it's setup to
flash the eMMC..

Regards,