BeaglePlay does not power on anymore (quick red `PWR` led flash)

When I plug in my USB C cable for (powering up the BeaglePlay), it shows a very quick red LED flash
(it’s near the user LED’s, I think) and that’s it.

What are some things I can initially do to troubleshooting this?

Things I’ve tried so far:

  • I’ve tried a different USB-A to USB-C cable but there was no difference.
  • And I’ve tried powering from a different PC workstation but no difference.

Connect to the linux debug port and see what is going on. It could still be running uboot and/ or the kernel might be loaded.

Also make sure you have the correct image on the SD card.

I think I might have fried it while being in hurry earlier…

The BeaglePlay was on and was being powered by one of my workstations (workstation #1) …and I hooked up a module via a Grove connector cable (normal type) to the Grove connector on the BeaglePlay.

Once I had the module hooked I noticed the module wasn’t powering (and not thinking) I hooked up a different USB C power cable from my module to my other workstation to power it (workstation #2).

When I did that everything shutdown, at least I think that’s how it happened. So the module was connected to the Grove connector on the BeaglePlay and the module received power from my other workstation via a usb c cable.

I just got the BeaglePlay last Friday so if I did indeed fry it I might have set a record here for frying a beagleplay the quickest. lol

I don’t have a SD card I just used the onboard flash image. I guess I could order a micro-sd and also order a usb to uart device, never used one of these. The Adafruit one titled " USB to TTL Serial Cable - Debug / Console Cable" recommends it for the beaglebone black so maybe. I’ll have ask around for the right one. Can the USB to TTL Serial Cable access a console even w/o any power? I don’t have any power. Thanks!

No, however if desktop manager breaks and then dumps you can still access the board and turn it back on. You can also see exactly where in the boot process you are, when you need it , its priceless.

If you have a difference of potential between workstation #1 and #2 you have an issue that could kill you. Please check your main wiring make sure you have proper bonding and grounding going on.

More than likely you zapped it with static, very easy to do especially with certain types of shoes and a chair that is a static generator. When the cold weather arrives the air gets very dry.

One of my cats has fur characteristics that are very conducive to triboelectric charge build up. Dry air and rub him then get close to the tip of his ear and ZAP!! The other cats don’t build a charge like Sammy does.

There’s definitely a possibility as far as static, especially lately. I went to pet my cat earlier and I got static shocked from her fur! lol

That being said, I am pretty sure that this was just a really dumb mistake on my end. Even someone with very little electronics knowledge is asking for trouble hooked up like this. :smiley: And just in case this helps someone in the future I’ll post photographs (better than words) to show what I did, as embarrassing as that is. lol

When you mentioned grounding/bonding I looked this up and researched it and noticed how I had this hooked up I am pretty sure the surge of voltage from my main pc zapped the beagleplay. This could have easily been avoided if I just slowed down and thought about it.

Here is the photo of how I had the BeaglePlay hooked up. My more powerful workstation I was using for other things so I didn’t want to tie that up. So I hooked up the BeaglePlay to an inexpensive mini pc but the power adapter wouldn’t reach the surge protector so I grabbed a cheap extension cord. :confused: for the mini pc …this when into the surge protector (photos).

In fact both workstations were plugged into the same surge protector…I then had a module connected via grove into the beagle…and when I plugged the other usb-c to the more powerful workstation. :confused: (photos in 2nd section)

Beagle and minipc






overview of the entire disaster…it’s tough to see but the usb c from that little module is going into the dell workstation.


When I did this everything shutdown…for the photos I deliberately hooked it up just like I had it (this could be dangerous afaik but I wanted to show it anyway).

FWIW, I was surprised that we would actually see the PWR red led light up again, I assume notthing… But assume it’s the frying it more? Again, this could dangerous as far as I know so might not want to do it again but good to show other n newbies. :zap:

1 Like

If the pwr led is on, the board might still be good. With out looking at the schematic the led should be down stream of the VR. If any thing was going to blow it would have taken the VR out, unless it fused. I would not toss the board until you get your ttl to usb adapter connected.

1 Like

Sounds good then. I’ll order a ttl to usb adapter tonight.

If all else fails I’ll just pick up another BeaglePlay and lesson learned, it’s not like they are expensive. Thanks!

1 Like