BeagleV-Ahead - debug terminal problems

I’ve just received my BeagleV-Ahead board. I’ve powered up but the output from debug terminal is just garbage. Are there any problems with the UART?
I’m using an FTDI serial cable @115200 baud.

Regards, Mike.

HI @MikeJames this is a pcb mistake that didn’t get fixed in time, @lorforlinux is going to be adding pictures to BeagleBoard Documentation — BeagleBoard Documentation … There’s actually 2 uarts routed, the two NC’s are actually for another co-processor… which can break bootup…

On my early alpha, these are labeled ATX/ARX… (audio?)…

Grabs production board… for better picture:

Using the Raspberry Pi Debug Probe: Buy a Raspberry Pi Debug Probe – Raspberry Pi


FYI - I found the best success with CP2102 uart adapter. My random assortment of PL2302 and FTDI adapters did not work and resulted in garbage output.

Screenshot from 2023-07-13 12-37-44
Screenshot from 2023-07-13 12-37-38

Thanks. I used my RPi Debug Probe - no problems. Funny the FTDI lead not working even when connecting with 3 wires.

@MikeJames Yes, that’s very weird. Even a cheap clone with FT232R as shown in the picture below will work fine it’s just the cable that is not working with the board.


FYI - for people that can order from Amazon in USA, I just received this and can confirm it works with the BeagleV Ahead
" HiLetgo CP2102 USB 2.0 to TTL Module Serial Converter Adapter Module USB to TTL Downloader with Jumper Wires"

I got this problem, too! Serial… Seriously…!

I believe the V_Low is not “low” enough for TTL. This might explain the garbage we are seeing on most of USB-to-UART TTL.

Not sure UM3304 was a good choice?



Hello all, I’m new to the forum and feel like I’m in over my head. At this point, I’d like to simply connect to, and log in, to my BeagleV-Ahead board.

I’m so far unsuccessful in accessing my BeagleV-Ahead through the Debug UART, as shown. I have successfully logged in with ssh through the LAN/Ethernet connection. I’m using the software image that came on the board.

I’m using the AdaFruit Raspberry Pi Debug Probe Kit. On the debug probe board, I’m connecting to the “UART” port (not the “DEBUG” port). On the BeagleV-Ahead board, I’m connecting GND, RX, and TX, as shown in the picture.

I run:
tio /dev/ttyACM0
[ttyACM0 is what shows up in my /dev directory when I plugged in]

I get the tio startup prompt, but never get to a connection. The activity indicator LEDs next to the UART port on the debug probe board don’t light up at all.

Please let me know if I’m missing a step.

Alternatively, should I be able to log in through a USB connection? I tried connecting a micro-B USB 3.0 connector, but nothing shows up in /dev/tty* when I plug that in to my computer’s USB port. (x86_64 Linux, Pop!_OS).

try swapping RX and TX, JIC
logging in via micro-B, don’t think so.
ssh works, once ya find the ip
something like
sudo nmap -sP
depending on your subnet

This worked for me. With the Adafruit RPi debug probe, I had to connect like so:

Yellow → Board TX
Orange → Board RX
Black → Board GND

which matches Robert’s pictures.

1 Like

Still no luck…

I’m using this debug probe kit:

I’ve connected the leads to the BV-A as instructed, with orange-yellow in both positions. At the debug probe board, I’m connected to the "U"ART side, not the "D"EBUG side. From there, I have a USB connection to my Linux laptop. I run “tio /dev/ttyACM0”, but never get connected.

One thing I notice is on the debug probe board, there are activity LEDs, but they never blink. I’ve done the usual: unplugging/replugging every connection, etc.

I still have the software load that came on the board.

I have connected successfully through wired LAN connection.

Is there any other troubleshooting I can do on the serial debug connection? Is there an alternate way to connect, i.e., through the superspeed micro-B connector?

1 Like

I think the cable length of the TTL signals is a big part of this. I just ‘fixed’ 5 PL2303 adapters (2 different types) by shortening the wires. All 5 didn’t work as original, then shortening the wires to about 20cm they all now work.

OK, did a little more digging and looked at some signals.
First picture is uart output with nothing attached.
Second is with PL2303 RX hooked up to board TX, with short wire. This works and I get good serial output.
Third picture is of longer wire. For this test I added about 60cm of jumper wire to the connection.
It looks like the 1.8 to 3.3 volt converter becomes unstable at this point - my (software guy) guess is the bidirectional detection is unhappy with the capacitance/impedance of longer wire.

Looks like short wires are going to be required for reliable serial port connections.

Separate posts due to new user restrictions.

I had a spare ftdi USB cable that was also throwing garbage, I shortened the cable to 20cm as suggested and can also confirm that this worked.