Begleboard sleep problem

Hai

I am using beagleboard xm Rev C and I am using kernel 2.6.32
My problem is that when I entering the command

echo mem > /sys/power/state

for resume the beagleboard it worked. And I got the message

[ 129.973999] PM: Syncing filesystems … done.
[ 131.147247] Freezing user space processes … (elapsed 0.02 seconds) done.
[ 131.178558] Freezing remaining freezable tasks … (elapsed 0.01 seconds) do.
[ 131.202239] Suspending console(s) (use no_console_suspend to debug)

But when I enter the data to the serial port it doesn’t get wake up… I tried from minicom also…

But in Kernel 3 and it works…

Why this happening on kernel 2.6.32.
Do I need to enable anything on kernel configuration. ?

Thanks…