Belkin N150 in BeagleBone and Kernel 3.2.5

Hi,

I have been struggling with this for weeks, so I decided to claim some help.
My beaglebone is running image v2012.02 which is kernel 3.2.5+, and I cannot make it my usb wireless device to work.

once I connect the usb, the driver looks good:

root@beaglebone:~# lsmod
Module Size Used by
rtl8192cu 73001 0
rtl8192c_common 53126 1 rtl8192cu
rtlwifi 57404 1 rtl8192cu
g_mass_storage 24010 0
mac80211 146552 3 rtl8192cu,rtl8192c_common,rtlwifi
cfg80211 122987 2 rtlwifi,mac80211
rfkill 14605 1 cfg80211
ipv6 210434 16

However wlan0 doesnt look to be available:

root@beaglebone:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

root@beaglebone:~# ifconfig
eth0 Link encap:Ethernet HWaddr D4:94:A1:38:1D:C4
inet addr:10.0.1.3 Bcast:10.0.1.255 Mask:255.255.255.0
inet6 addr: fe80::d694:a1ff:fe38:1dc4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:289 errors:0 dropped:1 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:105290 (102.8 KiB) TX bytes:8765 (8.5 KiB)
Interrupt:40

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:140 (140.0 B) TX bytes:140 (140.0 B)

If I try to enable it, I get this error:

root@beaglebone:~# ifup wlan0
Could not read interface wlan0 flags: No such device
Failed to initialize driver interface
ifconfig: SIOCGIFFLAGS: No such device

I found in another thread that beaglebone looks like that doesnt use ifup ! it uses something called ‘connman’ which i couldnt figure it out how to make it work with the N150 usb wireless.

thanks in advance.

What does lsusb output?

thats lsusb output:

root@beaglebone:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 050d:1102 Belkin Components
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(looks all fine for me)

and btw i am running v2012.01.

output:

The Angstrom Distribution beaglebone ttyO0

Angstrom v2012.01-core - Kernel 3.2.5+

Any help in here?

I tried:
insmod /lib/modules/3.2.13/kernel/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko
but I got:
insmod: error inserting ‘/lib/modules/3.2.13/kernel/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko’: -1 Invalid module format

also in dmesg I have:
[15762.305849] rtl8192cu: disagrees about version of symbol module_layout

That means:

*means that the module was compiled against a* different kernel than the one you are trying to run.

So obviously I need to recompile...

I got driver source from realtek pages, and I am following:
[http://cwraig.id.au/?p=507](http://cwraig.id.au/?p=507)


Hope I will get somewhere :)

Dne sobota, 14. april 2012 20:33:37 UTC+2 je oseba Arthur Neves napisala:

Hi,
I too have been struggling to get wifi working. I initially tried with the tiny Belkin, and RT8192CU, but moved on to a different adapter. I have it working now, (see my separate post for the details.) I will go back now to the belkin and try it again.

I will let you know.

Cheers,
Con