Belkin USB hub does'nt work

I recently purchased a Belkin USB hub (self powered) f5u307, it works
pretty well with my laptop(with linux running).But it is not detected
on my beagleboard.I tried some other USB hub,that works fine with the
board.I am using Beagleboard Rev.B6. Are their any specific drivers
for Belkin USB hub? Or is there any power problem(due to limitation of
the current beagleboard can give),since the power LED on the hub
does'nt glow on connecting with the beagleboard.Thanx in advance..

Are you self powering the hub? I have Belkin working with Beagleboard
REV B and C boards.

Some times if Cables are not good then I have seen similar issue. If
you have another HUB working then the kernel configuration should be
fine. Try with default Linux validation kernel to test the setup.

Regards,
Khasim

to my surprise, one day the HUB worked bt now it has stopped working
again. It works fine on my PC as there is no need of external power
there, but it is causing troubles while using with Beagle Board.
Please suggest me some solution.