Bitbake unable to obtain package linux-mainline-3.2.18-r121b

I just want to confirm that the problem exists.

W dniu czwartek, 13 września 2012 17:43:25 UTC+2 użytkownik Marcel napisał:

I am able to obtain the source using git.

Could you write how to do it?

W dniu niedziela, 16 września 2012 12:31:04 UTC+2 użytkownik valdez napisał:

I just want to confirm that the problem exists.

W dniu czwartek, 13 września 2012 17:43:25 UTC+2 użytkownik Marcel napisał:

Hi,

I’m trying to build a new kernel for the beagleboard (running Angstrom). I have set up openembedded using the set-up scripts provided. When resolving the task queue dependencies I get the following error:

`

NOTE: Running task 279 of 318 (ID: 2, /home/marcel/setup-scripts/sources/meta-ti/recipes-kernel/linux/linux-mainline_3.2.bb, do_fetch)
NOTE: package linux-mainline-3.2.18-r121b: task do_fetch: Started
WARNING: Failed to fetch URL git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;branch=linux-3.2.y;protocol=git, attempting MIRRORS if available
ERROR: Fetcher failure: Fetch command export HOME="/home/marcel"; export SSH_AGENT_PID=“1340”; export SSH_AUTH_SOCK="/tmp/keyring-i3h6zk/ssh"; export GIT_CONFIG="/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux/etc/gitconfig"; export PATH="/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux/usr/bin/armv7a-angstrom-linux-gnueabi:/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/beagleboard/usr/bin/crossscripts:/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux/usr/sbin:/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux/usr/bin:/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux/sbin:/home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/sysroots/x86_64-linux//bin:/home/marcel/setup-scripts/sources/openembedded-core/scripts:/home/marcel/setup-scripts/sources/bitbake/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/marcel/setup-scripts/sources/openembedded-core/scripts"; tar -xzf /home/marcel/setup-scripts/sources/downloads/git2_git.kernel.org.pub.scm.linux.kernel.git.stable.linux-stable.git.tar.gz could not be run:
None
ERROR: Function failed: Fetcher failure for URL: ‘git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;branch=linux-3.2.y;protocol=git’. Unable to fetch URL from any source.
ERROR: Logfile of failure stored in: /home/marcel/setup-scripts/build/tmp-angstrom_v2012_05-eglibc/work/beagleboard-angstrom-linux-gnueabi/linux-mainline-3.2.18-r121b/temp/log.do_fetch.17002
NOTE: package linux-mainline-3.2.18-r121b: task do_fetch: Failed
ERROR: Task 2 (/home/marcel/setup-scripts/sources/meta-ti/recipes-kernel/linux/linux-mainline_3.2.bb, do_fetch) failed with exit code ‘1’
NOTE: Tasks Summary: Attempted 314 tasks of which 313 didn’t need to be rerun and 1 failed.

Summary: 1 task failed:
/home/marcel/setup-scripts/sources/meta-ti/recipes-kernel/linux/linux-mainline_3.2.bb, do_fetch
Summary: There was 1 WARNING message shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

`

Checking the log-file I found bitbake tried the following sources for download:
http://sources.angstrom-distribution.org/git2_git.kernel.org.pub.scm.linux.kernel.git.stable.linux-stable.git.tar.gz

http://downloads.yoctoproject.org/mirror/sources/git2_git.kernel.org.pub.scm.linux.kernel.git.stable.linux-stable.git.tar.gz

http://sources.openembedded.org/git2_git.kernel.org.pub.scm.linux.kernel.git.stable.linux-stable.git.tar.gz

The angstrom mirror seems to be corrupted. I tried downloading the archive multiple times on multiple hosts, but all failed to unpack (Unexpected EOF error). The other two mirrors result in a 404 error.

I am able to obtain the source using git. However, I don’t know how to let bitbake find it.

Is there a work around?

W dniu niedziela, 16 września 2012 12:31:04 UTC+2 użytkownik valdez napisał:

The error message refers to the source it is trying to obtain. (I’m on a different machine now, so can’t look it up for you)

I tried “git clone git://the_source_it_refers_to/…” in a new directory and it was able to obtain the code. However, I haven’t figure out yet what bitbake does afterwards and how to do these steps by hand.

Problem seems to be that bitbake prefers mirrors over the original git source and doesn’t try it even when mirrors fail.

I’m not very familiar with OpenEmbedded/bitbake. Would anyone know a way to install this dependency by hand?

Thanks. I am on a different machine and not familiar with bitbake also. But I will dig today evening and try to figure out how to work around. I had similar problems with crosstool-ng and u-boot make so hope to manage with bitbake :slight_smile:

2012/9/17 Marcel <gentics@gmail.com>

Ok, found a way to circumvent this issue.

Information on mirrors is stored in:
sources/meta-angstrom/classes/angstrom-mirrors.bbclass
sources/openembedded-core/meta/classes/mirrors.bbclass

Remove those files from the sources dir (or rather create a back-up outside the sources dir) and create an empty file instead (e.g. using touch). Now bitbake will no longer look for mirrors, but will download from the original git source instead. I would recommend restoring the orignal files afterwards, as this could speed up downloading other dependencies.

I’m finally at home and it is very nice to see solution :slight_smile: I changed these files names adding .backup and created empty as you suggested.
But after:

`
bitbake virtual/kernel

`
it still stay (more than 2 hours) in step:

`
NOTE: package linux-mainline-3.2.18-r121b: task do_fetch: Started

`

Hope it will finish some time…

W dniu poniedziałek, 17 września 2012 15:34:12 UTC+2 użytkownik Marcel napisał:

It works! Marcel thanks for saving my time (and nerves :D)!

I was very impatient, so I stopped it, removed all files and directories downloaded with:

git clone git://github.com/Angstrom-distribution/setup-scripts.git**,**
removed .oe directory from my home and repeated all commands (obviously with Marcel solution).

BTW:
I hoped that when I remove all what I mentioned above, the bitbake will start all things again. But it started from that fetching step. 
How to clean all things applied with these steps [http://www.angstrom-distribution.org/building-angstrom](http://www.angstrom-distribution.org/building-angstrom) ?

W dniu poniedziałek, 17 września 2012 21:32:04 UTC+2 użytkownik valdez napisał:

I tried this solution, but I’m getting the following:
ERROR: Unable to parse angstrom-mirrors: ParseError in configuration INHERITs: Could not inherit file classes/angstrom-mirrors.bbclass

Any thoughts on what went wrong?

I followed this instruction: http://elinux.org/EBC_Exercise_08_Installing_Development_Tools
With Marcel solution it works. There is a part about INHERIT. Maybe that change will help you.
If not, you have to count on advanced users :slight_smile:

Cheers,
Valdez
W dniu piątek, 21 września 2012 05:29:16 UTC+2 użytkownik Walter Schilling napisał:

I figured it out late last night. angstrom-mirrors.bbclass is different from angstron-mirrors.bbclass … Eyes didn’t see the small difference… Dange of using a VM and a small screen.

:slight_smile: