Bluetooth Connectivity Issues

Hello all ,

Got my new BBBW yesterday and I just went over an article of setting up beagle box wireless and i am successfully able to enable wifi and ping… now trying to enable Bluetooth but i encounter the following issues, any help will be greatly appreciated.
Here are the steps i followed :
[bluetooth]# scan on
Discovery started
[CHG] Controller 6C:C3:74:E7:89:DA Discovering: yes
[NEW] Device 53:93:6D:6D:12:AF 53-93-6D-6D-12-AF
[NEW] Device D0:81:7A:8A:F4:C4 Aravind Reddy’s iPhone

[bluetooth]# pair D0:81:7A:8A:F4:C4
Attempting to pair with D0:81:7A:8A:F4:C4
[CHG] Device D0:81:7A:8A:F4:C4 Connected: yes
Request confirmation
[agent] Confirm passkey 018547 (yes/no): yes
[CHG] Device D0:81:7A:8A:F4:C4 Modalias: bluetooth:v004Cp7005d0C30
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 00000000-deca-fade-deca-deafdecacafe
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 00001116-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 0000111f-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 0000112f-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 00001132-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device D0:81:7A:8A:F4:C4 UUIDs: 02030302-1d19-415f-86f2-22a2106a0a77
[CHG] Device D0:81:7A:8A:F4:C4 ServicesResolved: yes
[CHG] Device D0:81:7A:8A:F4:C4 Paired: yes
Pairing successful
[CHG] Device D0:81:7A:8A:F4:C4 ServicesResolved: no
[CHG] Device D0:81:7A:8A:F4:C4 Connected: no
[bluetooth]# pair D0:81:7A:8A:F4:C4
Attempting to pair with D0:81:7A:8A:F4:C4
Failed to pair: org.bluez.Error.AlreadyExists
[bluetooth]# connect D0:81:7A:8A:F4:C4
Attempting to connect to D0:81:7A:8A:F4:C4
Failed to connect: org.bluez.Error.Failed

Adding to the above, it holds the connection for a second when i try to connect to my mobile device.
[CHG] Device D0:81:7A:8A:F4:C4 Connected: yes
[Aravind Reddy’s iPhone]#

and reverts back to
[CHG] Device D0:81:7A:8A:F4:C4 Connected: yes
[CHG] Device D0:81:7A:8A:F4:C4 Connected: no
[CHG] Device D0:81:7A:8A:F4:C4 Connected: yes
[CHG] Device D0:81:7A:8A:F4:C4 Connected: no
[CHG] Device D0:81:7A:8A:F4:C4 Connected: yes
[CHG] Device D0:81:7A:8A:F4:C4 Connected: no
[bluetooth]#

Thanks
Aravind