Board doesn't boot

Hello

I currently have two boads, in one I have to enable more serial ports than the ones that are available, the default is 6, In order to make the post brief I will skip the details and write that I had to rebuild the kernel using Robert scripts from his github page (thanks Robert!!) and install the new image on the board.

I tried using my pc with ubuntu to make it fast and then install the new image on the board, however it did not work and in a desperate attempt I rebuild it directly in the board and proceed to install, it took two whole days with the board on, when I finished I rebooted it thinking it was necessary and thats when things went wrong, the debug screen from the JTAG output started to print garbage, not the usual power off sequence and the board turned off, it tried to boot but after 7 seconds it turned off, this is a recurring problem I have had and I know its from the PMIC not finding the DEV bit on, I had managed to bypass it with this trick: pull the sd out, turn on the board and wait 2 seconds and then insert the sd, after doing this the board started to boot normally (seems a problem with partitions), this time however it did not work.

I was puzzled, and tried a few other times with no sucess, I checked the JTAG and nada, nothing whenever I tried to turn the board on without a sd the debug at least showed me a message of inavlid partitions this time I got nothing, I tried the J5 jumper and still nothing happened, using my other board I tested the sd and booted fine (with the trick), the ttyS ports are listed to 0 to 9 which means the changes to the kernel image where sucessfull.

Did I “burned” the board for having it two days on? I know that doing the building in it is crazy wrong, I was suggested yocto, however I don’t have time to learn, knowing this and the way the board heats I put a 20 inch fan right beside it during the two days in order to avoid this.

Did I messed the Uboot somehow or perhaps something was corrupted in the eMMC? I find this hard to believe since I did not move nothing that I shouldn’t, just changed the uart ports size.

Regard

M

Hard to say, can you provide the u-boot messages you currently see
over the serial port?

Regards,

Well, the only thing I see is this:

ø

and when it turns off aftrer the 7 seconds is this:

À[00]

Not sure what’s going on on that board, but we’ve certainly seen nothing but a few stray characters come out on the console port when debugging our custom boards.

One thought which came to mind. I still haven’t tried building the kernel on a BB-X15 iteself (using imagebuilder). I’m still building on a PC, and then copying all of the kernel components to the SD card. However, a colleague of mine tried running yakbuild on a beaglebone black, and the entire disk partition filled up during that yakbuild, I’m guessing, because the partition size on the SD card was <=4GB, and that partition size doesn’t allow enough space for both the file system AND downloading and building the kernel source. So if yakbuild and or image builder needs to download the kernel source code tree (which is itself about 4GB) to your device and then build, and the partition size on your SD card is < 8GB, or you’re running from eMMC (partition size < 4BG), then could this be part of the issue??

What you describe is correct and it did happened the first time I tried, after finding out I build it through an usb, and I sill had over ~200 mb free in the disk partition of the sd and ~1gb in the usb when the building was over.