Bone LCD3 Ubuntu Support

Hallo Robert,

thank You very much for Your very quick response :slight_smile:

I am looking foreward to hear from You and to learn more about my mistakes I made with these board :slight_smile:

regads
Juergen

Ah, it's just the backlight:

sudo i2cset -f -y 1 0x24 0x07 0x09
sudo i2cset -f -y 1 0x24 0x08 0x60

tested with:
ubuntu@omap:~$ uname -a
Linux omap 3.2.23-psp18 #1 Fri Jul 27 20:46:04 UTC 2012 armv7l armv7l
armv7l GNU/Linux

Sorry, no idea if the touchscreen works yet..

Regards,

Hallo Robert,

thank You very much for Your help :slight_smile: :slight_smile:

It works fine … but the touchscreen does not work yet…

Best regards
Jurgen

Thanks! That got mine up and running too.

Jake

Hallo Jake,

my touchscreen is now working.
Please have a look at the following link…

https://groups.google.com/forum/?fromgroups=#!topic/beagleboard/xyT84cDwEsQ

After changing my /etc/modules the touchscreen works.

best regards

Juergen

thanks for the information! applying the pgp20 update and then the backlight changes I now see that the 3" LCD is working. excellent news. Adding the extra values to the /etc/modules now gives me touchscreen too. I’m nearly very happy. Why only nearly?

All I see on the screen is the word “Log”. I’m assuming this is saying “Login:”. The resolution must be set too high. How do I change this so that it resizes for the 3" LCD?

After a looooong break from doing anything BeagleBone related, I decided to give this a try once more. I found that I had to plug a usb host connector into the BeagleBone, then plug a keyboard and mouse in to this. I was then able to press ctrl+alt+F1 and I get a command line console that I can log into and use the BeagleBone and LCD3 cape directly.

Whilst this still doesn’t explain how I can change the resolution on ctrl+alt+F7 (which I’d still like to know how to do, if anyone knows how to do this?), it does mean that I can successfully use the LCD3 cape with the BeagleBone and Ubuntu.

I also found that the latest Angstrom image now recognises and boots up nicely with the LCD3 cape… but I want to stick with Ubuntu.

As I wanted to get this working with Ubuntu, I finally figured it out and thought I’d share, just incase another newbie like me wants to do the same thing.

Okay, from ctrl+alt+f1, login and sudo apt-get install xinput-calibrator (you’ll need this later).

to auto-turn on the LCD screen backlight, sudo nano rc.local - add the following two lines before the exit 0
sudo i2cset -f -y 1 0x24 0x07 0x09

sudo i2cset -f -y 1 0x24 0x08 0x60

then sudo nano /etc/lxdm/lxdm.conf - change the first line to be:
autologin=ubuntu

then sudo shutdown -r now

after the reboot, the LCD screen will then boot directly into the LXDM GUI, press the ‘start’ (?) icon, bottom left to get the menu, select Preferences and you’ll see ‘Calibrate Touchscreen’, press it and calibrate.

All should now be good. even after a complete unplug and restart everything works again as it should. hope it helps someone else.

…Now time to get GStreamer and FBI working :wink:

Will this work with the LCD7 cape?