Boot Doesn't Work after mkcard.txt

Use uBuntu 11.04 to do the job.

sudo chmod +x mkcard.txt
sudo ./mkcard.txt /dev/sde

According to the manual One 70MB FAT partition labeled as boot.
One ext3 partition labled as Angstrom.
I didn't see the labels so I mkdir boot and Angstrom_Demo.

copy MLO, u-boot.bin, and uImage in sequence to /media/boot/
Download Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 to /media/Angstrom_Demo/
tar -xjvf the above file and got all the directories/files underneath the tar file.

Insert the SD card to Beagleboard xM rev C and boot. It shows beagleboard.org with a dog and orange background. No more message after that. One one line.

Please help.

After you format the card you have to re-insert the card in your linux system to detect it correctly by your machine. Then, copy the image again.

john

Use uBuntu 11.04 to do the job.

sudo chmod +x mkcard.txt
sudo ./mkcard.txt /dev/sde

According to the manual One 70MB FAT partition labeled as boot.
One ext3 partition labled as Angstrom.
I didn't see the labels so I mkdir boot and Angstrom.

Before copying the files I remove the SD card and re-insert to the USB SD card reader.

copy MLO, u-boot.bin, and uImage in sequence to /media/boot/
Download Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 to /tmp

tar -xjvf the above file with -C /media/Angstrom and got all the directories/files in /media/Angstrom.

Insert the SD card to Beagleboard xM rev C and boot.

It showed a compass and big Angstrom for a few minutes.
Reboot the BB and the compass never showed up only beagleboard.org with a dog and orange background. No more message after that. One one line.

Reboot again got the same logo. The Compass/Angstrom never came up.

Please help.

Use uBuntu 11.04 to do the job.

sudo chmod +x mkcard.txt
sudo ./mkcard.txt /dev/sde

According to the manual One 70MB FAT partition labeled as boot.
One ext3 partition labled as Angstrom.
I didn't see the labels so I mkdir boot and Angstrom.

Before copying the files I remove the SD card and re-insert to the USB SD card reader.

copy MLO, u-boot.bin, and uImage in sequence to /media/boot/
Download Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 to /tmp

tar -xjvf the above file with -C /media/Angstrom and got all the directories/files in /media/Angstrom.

Insert the SD card to Beagleboard xM rev C and boot.

It showed a compass and big Angstrom for a few minutes.
Reboot the BB and the compass never showed up only beagleboard.org with a dog and orange background. No more message after that. One one line.

Reboot again got the same logo. The Compass/Angstrom never came up.

Please help.

tar ubuntu-11.04-r2-minimal-armel.tar.xz

Got a directory ubuntu-11.04-r2-minimal-armel with files setup_sdcard.sh and another tar file: armel-rootfs-201107070830.tar.

The procedure does not mention this second tar file. Do I tar this rootfs files and insert the SD card ro Beagleboard and boot?

Thanks.
Jim

The "setup_sdcard.sh" script takes care of everything IF you run it.. :wink:

Read: http://elinux.org/BeagleBoardUbuntu#Natty_11.04_2 for hints...
or just run "./setup_sdcard.sh --help"

Regards,