Boot fails with microSD: ** Bad partition specification mmc 1:2 **

Hi,

I received my new BBB few days ago and I’m eager to start playing with it.
I’m having problem trying to use the microSD as extra storage.

I Flashed the eMMc with the latest img:
BBB-eMMC-flasher-2013.06.20.img

It worked fine.
I followed then the instructions here:
http://circuitco.com/support/index.php?title=MicroSD_As_Extra_Storage

I partitioned the microSD card in the following partitions:

(I actually made many tests with various filesystem types)

I wrote the following text in uEnv.txt

`
mmcdev=1
bootpart=1:2
mmcroot=/dev/mmcblk1p2 ro
optargs=quiet

`

But then whe I put the microSD in the BBB and see what the serial console shows me I see that it stops saying:
`
** Bad partition specification mmc 1:2 **

`

mmc 1:2 refers to the value of bootpart in uEnv.txt
I tried with bootpart=1:1 and I get then
** Bad partition specification mmc 1:1 **

(I even tried after upgrading all packages with opkg update/upgrade)

So, what am I missing now?
The strange things is that few days ago I followed exactly the same procedure and it worked without any issue: the BBB boot withe microSSD in and later I could mount the both partitions.
But now it looks like something is changed.

Any suggestion?
Thanks in advance

PS. below you find the serial console output when I boot the BBB with the microSD in

Use the latest image. It has SD card support. http://circuitco.com/support/BeagleBoneBlack

Gerald

Hi Gerald,

thanks for your reply!
I followed your suggestion using the latest firmware.
After flashing the BBB I see now that the ID.txt files shows:

CLoud9 GNOME Image 2013.06.20

root@beaglebone:~# more /etc/version

Angstrom v2012.12
root@beaglebone:~#

root@beaglebone:~# uname -a
Linux beaglebone 3.8.13 #1 SMP Wed Sep 4 09:09:32 CEST 2013 armv7l GNU/Linux

I repartitioned my microSD as before (UENV and SD) and created the uEnv.txt in primary FAT32 partition (UENV ) as above.

If I insert the microSD into the BBB, the microSD is detected and the two partitions are automatically mounted under /media

root@beaglebone:/# cd /media/
root@beaglebone:/media# ls
BEAGLEBONE SD UENV card cf hdd mmc1 net ram realroot union
root@beaglebone:/media# more UENV/uEnv.txt
mmcdev=1
bootpart=1:2
mmcroot=/dev/mmcblk1p2 ro
optargs=quiet
root@beaglebone:/media#

The problem is when I reboot the BBB with the microSD already in.
I still receive the same error message as before (I attach the complete console output BBBlog.txt):

SD/MMC found on device 0
reading uEnv.txt
66 bytes read in 3 ms (21.5 KiB/s)
Loaded environment from uEnv.txt
Importing environment from mmc …
gpio: pin 55 (gpio 55) value is 1
mmc_send_cmd : timeout: No status update
**Bad partition specification mmc 1:2
U-Boot#

I thought (and hoped) the problem was due to the missing of CR-LF at the end of the uEnv.txt as I read in other posts, but it is not :frowning:

What I really don’t get is why and how I did manage few days ago to boot the BBB with the microSD in, just after following the instructions in
http://circuitco.com/support/index.php?title=MicroSD_As_Extra_Storage

But I can’t know achieve the same result.
(I had to re-flash the BBB from scratch because I did later on other mistakes … I’m learning :slight_smile: )

Clearly this **Bad partition specification mmc 1:2 error message is related to the following settings in the uEnv.txt
mmcdev=1
bootpart=1:2

But why now suddenly doesn’t it accept 1:2 while it did it few days ago?

Thanks in advance for any help/saggestion.

Marco

BBBlog.txt (2.64 KB)

Sorry,

After flashing the BBB the ID.txt contains:

CLoud9 GNOME Image 2013.09.04

and not

CLoud9 GNOME Image 2013.06.20

as I wrongly wrote in my previous post.

BR
Marco

That is what it should say.

Gerald

I thought (and hoped) the problem was due to the missing of CR-LF at the end of the uEnv.txt as I read in other posts, but it is not :frowning:

I have read that it must be in Unix format, but you imply yours is in DOS format.

BINGO!

I run dos2unix and it booted even with the microSD inserted :slight_smile:

Thanx a lot Stephen!

had a similar experience, setting up the SD card from Windows. At first, it failed, since Windows had put CR/LF into the text file. A bit of editing with Hex Editor Neo removed the CR, then it worked fine as auxiliary storage, even mounting it on the Windows desktop when the BBB was connected via USB (GREAT!).

Then I used that same SD card to reflash the BBB (a process which obviously destroys the partition table on the SD card).

After reflashing, I put the card back into the Windows machine, reformatted it (twice, with intervening removal of the card, to get Windows to recognize the full 32GB), and put the uEnv.txt file onto it.

Putting that into the BBB, the BBB would no longer boot properly.

Two days of fiddling later, and after buying another SD card to compare (it worked fine, again), I discovered the broken SD card had no partition, and I couldn’t find a nice way to get Windows to create an MBR partition on an SD card.

Booting BBB with HDMI/keyboard/mouse, but without the broken SD card, I could then plug in the SD card, reformat it properly in Angstrom (Applications → System Tools → Disk Utility, select that SD card, unmount it, select Format Drive in the top left part of the screen, and request MasterBootRecord format).

Problem solved. Whew - two days of time wasted!

Jim