Boot problems

I think my beagleboard (revision C3) is having hardware problems
reading the SD card. I would very much appreciate the groups help in
figuring this out. I've read the documentation and not found a
solution.

I have two cards I mainly use - an Angstrom image and a restore image
I created from the Rev C Validation document.
I took couple backup images via dd if=/dev/sdb .. as soon as they
were created. I restored from these images to verify that they
function correctly.

Lately whenever I try to boot from either of these cards (or a newly
imaged Angstrom card) my boot process is hanging.
The point it hang varies, sometimes at Loading u-Boot.bin from mmc,
other times at "Loading Linux". Many times I'm getting random
gibberish during boot as well, that eventually hangs.

I was thinking these problems may have been caused by the serial
interface cable, but it doesn't happen when booting from NAND. I
verified the serial settings for minicom are correct.

you might like to give a shot to diagnostics & validation.

http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation

Remake the SD-card partition and make sure the order & name of the
files you copy.

In my case it worked, when i accidentally flashed NAND wrongly.

Kunal

Kunal, per the original post I already tried that...

If you think you have a HW issue, then I suggest you request an RMA. We have had several users damage their SD card connectors over the past several weeks due to improper insertion of the cards. This may be your issue.

Gerald

For me it hangs after decompressing the kernel. I dnt know why it
happens? I am also not able to type anything through terminal.

-Kaushik