Booting Angstrom

I am having trouble running Angstrom on a Beagleboard-xm (rev B). I have been following the tutorial provided at ( After inserting the card into the BeagleBoard and applying power, I get plenty of stuff on the serial port, eventually ending in “done, booting the kernel”. At this point the Angstrom compass logo shows up on the screen with a progress bar which moves along until slightly past half way. I have tried the same procedure on two different microSD cards with the same result. Any ideas on what is going wrong or how to figure this out?

I am using Ubuntu 11.10 to create the SD cards by following these procedures:
//Insert SD card

//With gparted:
//create partition table
//format everything to ext3

//safe eject the card or run this command twice
sudo sh ~/BeagleBoard/Angstrom3/mkcard.txt /dev/sdb

//copy MLO and u-boot.img to /media/boot by hand

//remove and instert card

sudo tar -xjv -C /media/Angstrom -f ~/BeagleBoard/Angstrom3/Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2

//safely eject the card
//remove from computer and insert into beagleboard
//apply power to board

Any help is greatly appreciated,

Do you get any debug messages on a console?

I’m not sure what to make of the freezing progress bar, but I had some trouble with MLO and U-Boot from that demo page – it was detecting the wrong amount of RAM on the BeagleBoard C4 (!topic/beagleboard/8fJ9m9PCLHQ)

I don’t know if the XM has the same issue (who knows, maybe it’s freezing because it tried to access non-existent RAM), but link above might be of interest to you.


I do not get any error messages once the Angstrom logo shows up.

Tried booting with and without pressing the user button. Here’s serial port output I get with/without pressing the user button & I have been looking at these logs, but do not know what information is significant or erroneous.

While researching we discovered this page which describes the problem. Not sure how to check or fix some of the described causes (like boot args). Where should I look?

Thanks again,

Hi Nick,

I suspect that you stop seeing messages due to “Cause #1 - The linux console boot parameter is incorrect”. Newer kernels need the console to be ttyO2, but older ones need ttyS2. Your kernel is version 2.6.32 (line 39 of your pastebin), which is old.

You’ll need to find a way to set those boot-args/environment-variables. According to your pastebin, you have one of the newer versions of U-Boot, which looks for boot args in a file called uEnv.txt, which you don’t seem to have (see lines 32-34 of your no-userbutton pastebin). Unfortunately, I had a quick search but couldn’t find a good default uEnv.txt to use; see if you can find one. Just remember that you want ttyS2.

Also, I just realized that you said you followed the tutorial at the BeagleBoard demo page. The BeagleBoard and BeagleBoard-xM are different – the xM does not have on-board NAND storage (see line 16 in your pastebin), so all the NAND commands are probably meaningless. I’m not sure how this might affect you, as I’ve never used an xM.

I found an old tutorial for the xM at . Some of it is outdated (it talks about boot.scr, which has since been replaced by uEnv.txt), but I still found something interesting:

a single USB host port cannot supply enough power to the board … the bootloader will load the ramdisk and uncompress the kernel and hang there, or it might even start the bootsequence but will fail at some point with no obvious reason

Do you have enough power?


I had the same problem as you…
Write these lines into the uEnv.txt file:

mmcroot=/dev/mmcblk0p2 rw

I have encountered another problem, when the Angstrom boots, the USB hub is shut down.
I also have Rev B board, there is a pin that turns the hub power ON, the polarity of that pin in Rev C is different than in Rev B, where can I find uboot or kernel for Rev B board, does someone have an idea what to do?

Thanks for your comments JKSH and Greg. I ended up following this tutorial ( including all of the fixes suggested in the comments. My BB is now up and running!

My next roadblock is gaining access to the serial port. I want to be able to receive data from an external accessory. Right now when I connect a second computer Angstrom wants to let me remote login. I want to disable this feature. From my research this can be done by changing the boot arguments. Also the only way to do this is by creating a uEnv.txt file on the boot partition (like both of you mentioned). I found a little info on it here (

I first tried to increase my resolution by following this tutorial ( My uEnv contained one line (dvimode=“omapfb.mode=dvi:1680x1050MR-16@60”) and I was able to boot with high resolution.

Attempting to disable remote login through the serial port I followed the suggestion here ( Changing my uEnv.txt to (dvimode=“omapfb.mode=dvi:1680x1050MR-16@60”
console=null). During previous boots, I get lots of messages after “done. booting linux” and eventually the angstrom login screen (below) displayed on the serial port.

>       >                  .-.
>   >   >-----.-----.-----.| |   .----..-----.-----.
>       >     > __  |  ---'| '--.|  .-'|     |     |
>   >   >  >  >     >---  ||  --'|  |  |  '  | | | |
'---'---'--'--'--.  |-----''----''--'  '-----'-'-'-'
                -'  |

The Angstrom Distribution beagleboard ttyS2

Angstrom 2008.1-test-20080918 beagleboard ttyS2

beagleboard login:

With this new uEnv.txt file, all these messages in the middle are instead displayed on my BB’s external screen. But I still get the Angstrom remote login prompt. :frowning: Next I read ( which mentions changing /etc/inittab, but this also did not fix my problem.

By running (cat /proc/cmdline) I can see that my current boot args are set to (console=null mpurate=auto buddy=none camera=lbcm3m1 vram=12M omapfb.mode=dvi:omapfb.mode=dvi:1680x1050MR-16@60 omapdss.def_disp=dvi root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait)

So, any ideas on how to disable Angstrom’s remote login prompt so that I can use the serial port for another purpose?


May you should have a look in the /etc/inittab file

Try commenting some of the getty mingetty (don't remember, sorry) lines and reboot

Yes, I tried this exact suggestion. Commented out the one relevant line, and rebooted. Unfortunately this did not succeed.


I'm not 100% sure, but maybe enabling auto-login (e.g.
might suppress the remote login prompt?