Booting from uSD card fails in BegaleBone Black


I am trying to boot BBB from uSD card but uboot is not working as expected , I am getting this error

Partition 1 Not Valid on device 0*
SPL:fat register err --1

I am using 8GB uSD card .
I tried to do little debugging actually MLO fails while registering FAT partition.

If you could help. I am using latest rev of BBB


It's either a bad build of u-boot or your partition setup is wrong.

Please take a look and review:


Hi Robert ,

As you mentioned i tried but still same problem .




Disk /dev/mmcblk0: 1983 MB, 1983905792 bytes
4 heads, 16 sectors/track, 60544 cylinders, total 3874816 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/mmcblk0p1 * 2048 100351 49152 e W95 FAT16 (LBA)
/dev/mmcblk0p2 100352 3874815 1887232 83 Linux

is it correct partition???

U-Boot SPL 2014.04-dirty (Jun 05 2014 - 20:31:45)

** Partition 1 not valid on device 0 **

spl_register_fat_device: fat register err - -1

ERROR ### Please RESET the board

boot from eMMC then on u-boot prompt i tried to run few commands

U-Boot# fatinfo mmc 0:1

** No partition table - mmc 0 **

U-Boot# mmcinfo


Manufacturer ID: 84

OEM: 5446

Name: MSTran Speed: 50000000

Rd Block Len: 512

SD version 2.0

High Capacity: No

Capacity: 1.8 GiB

Bus Width: 4-bit

What can be the issue Hardware ??



Hi Abhishek,

did you figure out the problem??