booting kernel 2.6.33-rc8

Hi there,

I cloned the OMAP kernel repsitory from tmlind and checked out in the
tag v2.6.33-rc8

so I did some pin mux config in the arch/arm/mach-omap2 :

then I used the default kernel configuration:

    make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- distclean
    make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
    make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- menuconfig //
in here I set everything that has to do with usb/ethernet adapters to
be built with the M (not built-in) I also activated the kernel pin mux
    make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- uImage modules

I got uImage in the folder arch/arm/boot

then I do
    make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
INSTALL_MOD_PATH=/media/rootfs modules_install

okay...I copied the uImage to my SD card as well...ands then when I
turn beagle board on I get:

## Booting kernel from Legacy Image at 80300000 ...
   Image Name: Linux-2.6.33-rc8-dirty
   Image Type: ARM Linux Kernel Image (uncompressed)
   Data Size: 1947012 Bytes = 1.9 MB
   Load Address: 80008000
   Entry Point: 80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

AND IT FREEZES idea what I did's been 15minutes
and no response..from the board...I will give it some more time..

I have the board connected also to a digital monitor and the screen is, it seems no kernel panic has occured....

I don't know what to do....any thoughts??

thank you very much, in advance.

Saul Andrade

This is a classic symptom of either:

a) kernel crashed while it was starting up
b) kernel is fine, but you haven't told it which tty to send the log

FWIW, using the vanilla omap kernel from tmlind's repo isn't
guaranteed to work - there are a lot of patches needed for a reliable
beagle. Check the OE recipe to see what's needed.


Hi Eric,

a)I've already built from tmlind successfully I tried
changing my .config before changing repo...I used koen's config for
kernel 2.6.32 and now I'm coming across another error..some undefined

drivers/built-in.o: In function `omap_dss_probe':
staging.c:(.text+0x15440): undefined reference to `dsi_dump_irqs'
make: *** [.tmp_vmlinux1] Error 1

b) my bootargs are fine (already tested with another kernel)

thanks for the tips,

Saul Andrade

Hi Eric,

a) I've already used the vanilla kernel and it worked,
before I change repo I tried using koen's config file for 2.6.32. Now
I'm coming across a dfferent problem, some undefined reference:

drivers/built-in.o: In function `omap_dss_probe':
staging.c:(.text+0x15440): undefined reference to `dsi_dump_irqs'
make: *** [.tmp_vmlinux1] Error 1

b) My bootargs are fine, I've already tested them with another
kernel...and the BB is connected also to an ecran.

Thanks for the tips,

Saul Andrade