Boris is spreading mustaches around at DESIGN East

Boris has been spreading mustaches around DESIGN East, sporting a
BeagleBone-based BeagleStache[1] collar running OpenCV face detection
with an added mustache. The demo is tomorrow, Sept 19th at 3PM in the
DESIGN East Theater located on the Expo Floor, during the DESIGN East
Gadget Freak DIY Lab[2]. There is a thread on Google+[3].

[1] http://beagleboard.org/project/stache (includes a couple of pictures)
[2] http://east.ubmdesign.com/expo/design-east-theater
[3] https://plus.google.com/u/1/104712705716996155416/posts/HQGjtxoQU27

This looks like fun. I’m trying to grow my own mustache, but it’s not taking. Here’s what I’ve done

  1. I’ve cloned the github [1]
  2. I’ve plugged in my 7 inch DVI cape and powered up.
  3. Plugged in the PS EYE and /dev/video0 appears. dmesg | tail reports
    [ 417.929607] usb 1-1: new high-speed USB device number 2 using musb-hdrc

[ 418.071850] usb 1-1: New USB device found, idVendor=1415, idProduct=2000

[ 418.071869] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

[ 418.071883] usb 1-1: Product: USB Camera-B4.04.27.1

[ 418.071894] usb 1-1: Manufacturer: OmniVision Technologies, Inc.

[ 418.110913] gspca_main: v2.14.0 registered

[ 418.124377] gspca_main: ov534-2.14.0 probing 1415:2000

[ 418.287330] usbcore: registered new interface driver ov534

  1. I run stache with ./stache 0 but capture = cvCaptureFromCAM(numCamera); always returns 0.

What am I missing?

–Mark

[1] git://github.com/jadonk/stache.git

This looks like fun. I’m trying to grow my own mustache, but it’s not taking. Here’s what I’ve done
I’ve cloned the github [1]
I’ve plugged in my 7 inch DVI cape and powered up.
Plugged in the PS EYE and /dev/video0 appears. dmesg | tail reports
[ 417.929607] usb 1-1: new high-speed USB device number 2 using musb-hdrc
[ 418.071850] usb 1-1: New USB device found, idVendor=1415, idProduct=2000
[ 418.071869] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 418.071883] usb 1-1: Product: USB Camera-B4.04.27.1
[ 418.071894] usb 1-1: Manufacturer: OmniVision Technologies, Inc.
[ 418.110913] gspca_main: v2.14.0 registered
[ 418.124377] gspca_main: ov534-2.14.0 probing 1415:2000
[ 418.287330] usbcore: registered new interface driver ov534
I run stache with ./stache 0 but capture = cvCaptureFromCAM(numCamera); always returns 0.

Did you try without the 0 argument?

Yes, same result.

–Mark

Are you invoking from an xterm on the LCD?

I’ve tried both opening a terminal on the screen and running that way, and ssh’ing in and running it that way. I get the same results.

I’m running the A6A image on an A5 bone.

–Mark

I've tried both opening a terminal on the screen and running that way, and
ssh'ing in and running it that way. I get the same results.

I really don't think it could make much difference, but have you tried
running 'make && make install' then using the icon on the desktop?

Can you run 'cheese' or any other application that captures from the camera?

Nope, cheese doesn’t work either. Sounds like a driver isn’t working. How do I fix it?

Did you ever manage to get this working? I’m having similar problems.