Bricked BeagleBoard


I seem to have a bricked BeagleBoard RevC4. It will not boot from
NAND, nor from the MMC.

I have read and very carefully followed the myriad of directions for
building a good MMC card. In particular, I have followed the
directions found here:

When I hold down the user button on reset, I get perhaps a dozen
garbage characters. Then the message, "Loading u-boot.bin from nand",
then perhaps two-dozen more garbage characters, then the standard,
"ECC Failed, page 0x00080700" message.

This happens prior to accessing the MMC card, because the exact same
thing happens without it card installed at all.

When I don't hold down the user button, there is no garbage, just the
standard TI message.

Any ideas?

Thanks in advance,


I would follow the instructions found here to re-flash the NAND:


If it says “loading UBoot from NAND” then it is not finding the SD card. Make sure you format the SD card with the required formatting tool or use the Image writer to copy the files over. Make sure you format it as FAT. Do not use FAT32. Make sure you copy the files over in the exact order as described.

If you can’t get it done, you can request an RMA and they can fix it in a couple of minutes for you.


This sounds to me like your SD card is not formatted correctly, but your NAND may still have the factory loaded items in it. If you don’t have the flash card in it, and you don’t press the user button, what exactly do you see on your board?


I tried the directions in your link to no avail, so thinking that
perhaps I was just bad at following directions, I had another engineer
quite experienced in board bring up try them from scratch. He also
can't get it to work. I'm beginning to think there is some sort of
hardware problem that makes it unable to read from the MMC under any
circumstances. In everything I have read about this topic over the
past couple of days, no one else has mentioned junk coming from the
UART. I have also tried the usb downloader posted elsewhere, but that
fails after writing only 512 bytes.


The exact output with the user-button held down is this:

...40W..... <about 20 junk characters that looks like the UART has
gotten out of sync>

Texas Instruments X-Loader 1.4.4ss (Jul 28 2010 - 16:59:13)
Beagle Rev C4
Loading u-boot.bin from nand
ECC Failed, page 0x00080700
e8 ff ff eb d4 3 0 eb 64 5 0 eb 6b 6 0 eb 8d 5 0 eb d0 3 0 eb 3 0 50
e3 0 0 0 1a 60 fd ff eb b7 59 0 eb 64 30 a0 e3
1 30 53 e2 fd ff ff 1a 17 1 0 eb 8f 0 0 eb 0 0 54 e3 10 80 bd 18 10
40 bd e8 4f 3 0 ea ec 20 9f e5 ec 10 9f e5 0 30
92 e5 e8 0 9f e5 c0 30 c3 e3 40 30 83 e3 0 30 82 e5 0 30 91 e5 d8 20
9f e5 1 30 83 e3 0 30 81 e5 0 30 90 e5 10 40 2d
  e9 5 30 83 e3 0 30 80 e5 0 30 92 e5 bc 0 9f e5 1 30 83 e3 0 30 82 e5
b4 30 9f e5 0 20 a0 e3 0 20 83 e5 8 30 43 e2 3
  20 82 e2 0 20 83 e5 0 30 90 e5 14 10 83 e2 0 30 90 e5 1 0 53 e1 fc
ff ff 3a 8c 40 9f e5 0 c0 94 e5 0 20 90 e5 14 30
  81 e2 3 0 52 e1 fb ff ff 3a 0 30 94 e5 3 0 6c e0 70 30 9f e5 3 0 50
e1 6c 0 9f 85 10 80 bd 88 68 30 9f e5 3 0 50 e1
  64 0 97 85

Finally figured this out. It was a hardware problem. The right-most
spring of the MMC card socket was bent and preventing the card from
making an electrical connection. I removed the spring and it now works
like a champ.

Moral of the story: I guess I'll be more careful putting in and taking
out the card.

Thanks to everyone for their willingness to help.


I suggest to request an RMA and let them take a look at it.


Glad to hear is was solved! Yes, those SD connecors can be an issue from time to time. They just don’t stand up to a lot of hard insertions, so just keep an eye on them. We do not see it often an dit is rare, but we have seen it before with other users.