Broken Beaglebone?

I have a Beaglebone A6 and I can’t get it to boot. I tried a fresh Angstrom image all 4 User LEDs light up for a few seconds and then User LED 0 blinks. When I screen the terminal nothing shows up although my Desktop PC is detecting it. Is my Beaglebone busted?

It may be busted, it may be fine. Not much information here to go on. The serial port should always be active and printing something, so I would work to get that piece to show up so you can see what is going on. With the LEDS lighting up, it sounds like it is booting up.

Which image are you trying to boot?


I’ve tried booting Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.04.13 and OpenROV’s custom Ubuntu image. They both appear to be doing the same thing. I’ve also tried writing the image to the SD card via Ubuntu image writer and with the terminal with no luck.

You should be able to remove the SD card. Hook up the USB port. Launch Putty or some other terminal program and see some characters coming out. See if you can get that to work.


Nothing shows up in the terminal. Should I be looking for anything important after running dmesg?

If the terminal is working, all you should see is CCCCCCCCCCCC. You can’t run dmesg if the terminal is not working.


The Beaglebone’s terminal is not working. After plugging in the USB, on my PC’s terminal should I look for anything with dmesg?

I don’t know if my last message went through. The Beaglebone’s terminal doesn’t work. Should I look for anything after running dmesg on my PC’s terminal?

You are not a subscriber. So all your posts are moderated. I decided to go to bed last night. If you want your posts to go through, then you need to subscribe.

If the terminal does not work, where are you typing dmesg?


I’m sending in my Beaglebone for RMA. Should I send the included SD card as well? Thanks for your help Gerald.

Just send in the request. They will tell you what to do.