Bug in git.sh script for kernel 4.19.31

I am trying to compile Robert’s kernel 4.19.31 and having some issues. I figured out the second complaint but am not sure about the first one

When I removed the offending code that deals with the email the download and setup worked. I haven’t went pas menuconfig but so far so good.

I don’t plan to create a Debian for my beagleboards X15 , just use a modified version of Robert’s kernel for Funtoo, Gentoo and Slackware.
The version I use for my Slackware development is RevC. The code compiled resides on a 2TB disk connected to the ESATA bus. That gives me enough room for work and it is faster than the micro SD or mmc
I haven’t tried with distc yet with Slackware, I have setup 3 Odroid HC1 for work on Odroid C2 and Allwinner boards, all with Funtoo of course.
For TI-RTOS specific code (DSP and M4) I use the SDK I created with yocto and yocto. Then I use custom packages to install the firmware.

michel@localhost ti-linux-kernel-dev-4.19.31-ti-r18]$ ./build_kernel.sh

  • Detected build host [“Fedora release 29 (Twenty Nine)”]
  • host: [x86_64]
    fatal: ni ceci ni aucun de ses répertoires parents (jusqu’au point de montage /) n’est un dépôt git
    Arrêt à la limite du système de fichiers (GIT_DISCOVERY_ACROSS_FILESYSTEM n’est pas défini).
  • git HEAD commit: []
    RPM distro version: [29]