C compiler cannot create executables


I am using armv7 .modules 2.6.32, in my beaglebaord c4. It said "gcc
not found" when I tried to compile a program. So I am trying to
install gcc in the beagleboard. The board doesn't have access to
internet so I cannot run opkg update. I installed the following
packages by downloading them in my pc:
binutils_2.20.1-r13.4.9_armv7a.ipk ,

After installing these packages, when I tried to compile i get the
following error message:

root@beagleboard:~/tmp# gcc main.c
linux-gnueabi/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status

I googled the error message and got a clue that I have to install

I have been trying to download libc6-dev that matches the version of
libc6_2.9-r37.4.6_armv7a.ipk but I cannot download it from the
Angstrom website. It says:
" Fatal error: Maximum execution time of 30 seconds exceeded in /var/
www/angstrom/repo/includes/functions.inc on line 29."
I hope to get some suggestion to solve this problem. Is there a quick
fix to this? Do I have to install some package? If so please also
mention to me the source for the package.


Go to narcissus and select the native toolchain option to get a rootfs with a toolchain

Thank you for the suggestion. I tried this one too but it did not
help. It works well when I try to build roofts without selecting the
toolchain but when I try to build it with the toolchain then either
some error shows up or the process never completes!
Some more ideas on it please?