can i use a simple USB-serial converter to connect to console?

hi Robert,

i wanted to ask how you did fixed the problem? was the problem with the
usb-to-serial converter or bad cabling, or anything else?

i have the same problem with the same usb-to-serial converter with the
pl2303 chip and the same vendor and product id but from an other
manufacturer (M-CAB) that i bought.

thank you in advance.

  rather than mess around with a full-blown port replicator to connect
to the console on my BB, i picked up a simpleUSB-serial converter and
am trying to use that to go fromUSBon my laptop to the serial port
at the other end, then a gender changer, and finally to the serial
(AT/Everex workalike) cable.

  here's the converter cable:

and when i plug it into my fedora 9 system, i see this in

Mar 14 18:18:44 localhost kernel:usb2-1: new full speedUSBdevice using

uhci_hcd and address 69

Mar 14 18:18:45 localhost kernel:usb2-1: configuration #1 chosen from

1 choice

Mar 14 18:18:45 localhost kernel: pl2303 2-1:1.0: pl2303 converter


Mar 14 18:18:45 localhost kernel:usb2-1: pl2303 converter now attached

to ttyUSB0

Mar 14 18:18:45 localhost kernel:usb2-1: NewUSBdevice found,

idVendor=067b, idProduct=2303

Mar 14 18:18:45 localhost kernel:usb2-1: NewUSBdevice strings: Mfr=1,

Product=2, SerialNumber=0

Mar 14 18:18:45 localhost kernel:usb2-1: Product:USB-Serial Controller
Mar 14 18:18:45 localhost kernel:usb2-1: Manufacturer: Prolific

Technology Inc.

i finally gave up and went back to using a targus port replicator,
but i'll try the USB to serial converter again today sometime. has
anyone else tried something like that? results?


When I try installing arm-2007q3-51-none-linux-gnueabi.bin on my Fedora
8 kernel it gives an error while launching the installer.
Error says: " No X11 DISPLAY variable was set, but this program
performed an operation which requires it."

Can anyone suggest how to overcome this error. ( I tried setting the
DISPLAY variable but to no effect)


Just for info, I use a pl2303 USB-to-serial converter without any problems with my BeagleBoard.
Have you try to shortcut Rx ans Tx pins of the pl2303 DB9 connector to see if you have an echo on the minicom screen when you press any key?




i tried to shortcut Rx an Tx through every cable up to beaglebord and it
works fine. also the pins on every connection seems to be correct.

i managed to setup a 10year old laptop with serial connection to test
the null-model cable it also works fine. and also there nothing on
serial terminal.

can i assume that something is wrong with the beagleboard?


Shorting TX and RX actually does not prove anything unless to short them on the ribbon cable. Have you done this? There is a chapter in the System Reference Manual that shows you how to do this to make sure you have the correct ribbon cable.


sorry, my mistake, i should have read a little bit more. the pins of my
serial cable were wrong - or i had the wrong serial cable.

the solution was a little bit of soldering because of

now everything seems to work fine.. until next problem arrives..


Glad you got it going!