can not disable HDMI in uEnv.txt

Hi,

I try to disable HDMI and emmc by editing the file in /boot/uEnv.txt:

optargs=quiet capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2G

Then I reboot , type:
cat /sys/devices/bone_capemgr.*/slots

See following:

Last login: Sat Jan 1 00:00:22 UTC 2000 on ttyGS0
root@beaglebone:~# cat /sys/devices/bone_capemgr.*/slots
0: 54:P—L BeagleBone RS232 CAPE,00A1,Beagleboardtoys,BB-BONE-SERL-03
1: 55:PF—
2: 56:PF—
3: 57:PF—
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-L Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI

With letter L, it means it is still enable… It does not work.,

So what is wrong, how could I do?

I am using latest Angstrom image (2013-06-20)…

Also, according to some post in Forum, no matter what I change the dtbo file in /lib/firmware/ (to disable /enable uart)
It has no effect when it reboot…
I just could change in run time, not in boot time…

Yiqing

I was a bit confused by this at first as well. The uEnv.txt file in /boot/ is not actually used during the boot process as far as I can tell. Both the uEnv.txt file and the uboot image used to start the kernel are located on the separate smaller FAT partition on the drive. So this is the file you will have to change to disable the capes.

For a system without an SDCard (so I can’t disable BB-BONE-EMMC-2G) I do the following:
Normally the BEAGLEBONE media directory auto mounts, but it didn’t for this test, so I mounted it manually.
Also note that if you are using an SD card, you would use mmcblk0p1 instead.

root@beaglebone:/# mount /dev/mmcblk0p1 /media/BEAGLEBONE

root@beaglebone:/# ls /media/BEAGLEBONE/
App Docs Drivers ID.txt LICENSE.txt MLO README.md START.htm autorun.inf u-boot.img uEnv.txt uEnv.txt~

root@beaglebone:/# cat /media/BEAGLEBONE/uEnv.txt
optargs=quiet drm.debug=7 capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

root@beaglebone:/# cat /sys/devices/bone_capemgr.*/slots
0: 54:PF—
1: 55:PF—
2: 56:PF—
3: 57:PF—
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-- Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI
6: ff:P-O-- Bone-Black-HDMIN,00A0,Texas Instrument,BB-BONELT-HDMIN

The uEnv.txt on the fat partition can also be edited in Windows when plugging the BBB in via USB.

Zach

Verify what you did, was actually passed to the kernel..

cat /proc/cmdline

Regards,

Didn’t you forget BB-BONELT-HDMIN?

I normally don’t reply but your info here saved me time, THANKS!!!

Key was to mount boot, modify uEnv.txt to disabled HDMI. This is exactly what I was looking for so I could use UART5