Cannot access BBB via wifi

Hi, I’m using BBB with Angstrom 3.8.13 and the Edimax EW-7811Un USB adapter.

I believe I got wifi to work as this is what I get with ifconfig:

ifconfig wlan0

wlan0 Link encap:Ethernet HWaddr 80:1F:02:BE:EF:CE
inet addr: Bcast: Mask:
inet6 addr: fe80::821f:2ff:febe:efce/64 Scope:Link
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3859 (3.7 KiB) TX bytes:10249 (10.0 KiB)

plus if I ping the IP (from the BBB terminal after accessing via USB) I get positive feedback.

However, here is (at least for me) the interesting thing: if I try to ping from my Mac (on the same subnet) I don’t get return… Needless to say, if I try to ssh the IP address it does not work as well… What’s going on? From BBB’s point of view I would say that I’m connected, but this does not seem true when I try to access from the Mac.

Did you start ping and ssh servers on BBB?
Are they running?

What does your /etc/network/interfaces file look like ? Also, does your Mac have any idea what the gateway IP of that subnet is ?

HI Tux,

I’m not 100% sure what you mean…
I can access the board via ssh (@ which is the USB address) and the ping on that address works as well.
Same when I try to access via ethernet, they both works.


Hi William,

here is what I get:

root@beaglebone:/etc/network# more interfaces
iface eth0 inet static

Do I have to configure it for wlan0 as well?


Did you check to see if your time/date were set right? The ntp was not setup right last time I did one and I could see my network but the network didn’t like me.

Hi David,

good suggestion. I checked but the time is correct.
Still trying to figure this out…


Can you post what you get with ~iwconfig wlan0. Iwconfig requires wireless-tools and I do not think that came on angstrom. That will tell you if you really are connected.

Hi David,

yesterday night I had a breakthrough: I logged into the router and found that it could not see all the devices connected (such as my laptop for instance) and obviously beaglebone. I thought that was weird as I know for sure wifi works for my laptop. I rebooted the router and the beaglebone was recognized and I could connect.

This morning I tried again and I could not connect, I had to reboot again.
What is going on? Maybe there is some setting I need to change on the router? I thought the router works well, we never had problems connecting via smartphones and laptops. Seems like the network is fine as long as you go straight to the internet without trying to interact with other people on the network… any explanation?

Btw this is my iwconfig output

root@beaglebone:~# iwconfig wlan0
wlan0 IEEE 802.11bgn ESSID:“wifi name”
Mode:Managed Frequency:2.422 GHz Access Point: E0:46:9A:37:C9:AB
Bit Rate=150 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=44/70 Signal level=-66 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:11 Missed beacon:0


Do you have your ethernet cable hooked up too? I have read about issues with trying to use 2 DHCP addresses with Angstrom.
Have you checked?
~# dmesg | grep wlan0
Maybe you can see it connecting/disconnecting?

Hi David,

I think I solved by updating (actually I also changed it) the router firmware. This also made my Chromecast work much better ;-).

That said I have issues having the connection configured properly, make the Ip static and so on. I know Angstrom connection manager is Connman (the system neglects /etc/network/interfaces file), but I haven’t been able to find a good guide online to use it. Any suggestion? Actually any good place to go learn how to configure networking on linux (angstrom above all) will be helpful.


Situations like this is the reason why I personally gave up completely on Angstrom. Availability on documentation alone is a huge killer. Or, if you prefer, the lack of documentation.

I run Debian on my own BBB’s and the reason is simple. I’ve been using Debian since the 90’s, have become very familiar with it, and there is documentation all over the web. Instructions / tutorials for x86 / ARM specific is mostly irrelevant, what works on one platform will very likely work on the next.

Anyway, I am not trying to talk you into using Debian, or even out of using Angstrom. I am simply relating to you how I dealt with that situation. There are ports or ARCH Debian Ubuntu, Fedora, and BSD that all run on the BBB. I also probably missed a few too . . . pick one, or stick with Angstrom( and get used to hunting for documentation assuming it exists ).

HI William,

yeah so far I have been pretty frustrated with Angstrom documentation…

I’m a newbie, so I don’t really have any bias for Angstrom a part from the fact that BBB ships with it preloaded… so I figured I would give it a shot. Plus it is described as a distro specifically developed for embedded systems. That said, I used to use Ubuntu (long time ago), so that is what I’m likely to switch to. Thanks!


Do a search for logic supply uwn100. They have a connection guide thatg worked for me on angstrom. Just jump down to the part where it says connecting.