Cannot flash latest Debian image to eMMC

I have a REV A5A Beaglebone Black.

I downloaded the image Debian (BeagleBone Black - 2GB eMMC) 2014-05-14 (http://debian.beagleboard.org/images/BBB-eMMC-flasher-debian-7.5-2014-05-14-2gb.img.xz) listed on http://beagleboard.org/latest-images.

Using Win32DiskImager I wrote the image to a 16GB microSD card. I inserted the card into the BBB, attached the serial debug cable (all other cables removed). Press S2 and hold down, apply power, let go of S3 after all 4 lights have lit up and things start flashing.

I have tried several times, leaving the board for 30 mins to well over 1 hour. Lights continuously blink in a repeating pattern. I typically get frustrated and pull power, and restart. Angstrom remains on the board.

The serial debug output I received is here: http://pastebin.com/AS0T8Xrt

Any help would be greatly appreciated!

-Blake

Just some additional clarification. I unzipped the archive before writing the image to the SD card. I let go of S2 (not S3) after all 4 lights lit up.

If more information/clarification is required, please don’t hesitate to let me know. I am anxious to get this thing flashed and willing to work with anyone that wants to help.

Hello,

The normal sequence is (S2 button not pushed):

  • MC1 (eMMC on-board flash), MMC0 (SD card), UART0, USB0
    S2 button pushed:

  • SPI0, MMC0 (SD card), USB0, UART0
    so … try flashing without the serial debug cable

good luck

Thanks for the input! I tried many, many, many times without the serial debug cable. In fact, I only resorted to buying the serial debug cable to assist my endeavor before resorting to asking the community. I saw many similar posts where people were asked to plug in a serial debug cable… I thought it might help.

If I try without the debug cable, the lights will flash for hours (i let it go for 2 hours). But when I plug in the HDMI cable, and it’s just sitting in the regular angstrom ui (forgive me I don’t know the name off the top of my head).

I WAS able to flash the latest Angstrom initially with no issues. So I think I have the process down, it’s just something to do with the combination of my board + the debian image.

Anyway, thanks for the input.

sorry to hear about your trouble. I’m not using Win32DiskManager so I can’t say what else could be the issue…

things to check => maybe you did this already?

  • checksum on the download?
  • is Win32diskmanager ok? can you use linux and the dd command ?
  • is the SD card good/formated properly before copying the image
  • good connection around sd card/holder


it should work ! crazy !!

Hey Blake

Have you tried this method. http://derekmolloy.ie/write-a-new-image-to-the-beaglebone-black/
It worked for me first time.

Hi Micheal,

I reviewed his blog, and yes that is exactly what I am doing. It works when I choose the latest Angstrom image (https://s3.amazonaws.com/angstrom/demo/beaglebone/BBB-eMMC-flasher-2013.09.04.img.xz), but not when I choose the latest Debian image (http://debian.beagleboard.org/images/BBB-eMMC-flasher-debian-7.5-2014-05-14-2gb.img.xz)

Thanks for your comments.

-Blake

I ended up buying a newer Rev C of the board. The image flashed within a few minutes. So I know it’s not a problem with the image or the SD card.

This is very strange, but I did end up getting the image flashed to the emmc. I booted normally into Angstrom, then inserted the SD card. I hit the RESET button, and waited. I noticed the debian login prompt and I just let the thing sit for a few minutes. It flashed within 20 minutes and now it’s working great. Could it be that it would have worked without holding the S2 button?

I hope this information helps someone else, but I’m starting to doubt it :smiley:

I have the same issue with my Rev A5A board and all debian images. Definetly there is some crap with images/board.

that post is from 3 years ago.
i am sure he figured it out by now
are you sure YOU are trying a 2gb image ?

I had no issues updating my 2gb bones