Cannot get audio over HDMI working

I’m trying to get audio to come out over my HDMI connection to my television.
The video over HDMI works fine.
I’ve read through and tried both of the listed resolutions that support audio. I tried each (separately) by adding
“optargs=video=HDMI-A-1:1280x720@60” to /boot/uEnv.txt and I can see a change in the displayed resolution when I reboot, but no audio.
I started with the 2015-03-01 Debian image from and have been adding packages to it using apt-get. “uname -r” reports “3.8.13-bone70”
For testing I’m using mplayer and a FLV video file I know has sound when I play it on my other computers.

Not sure what else to try as I am far from a Linux guru and Google searches either produce people saying it cannot be done or people who say it is super easy (but don’t explain how they got it to work).

I do know that when I run the fbset command I get
debian@beaglebone:~$ fbset

mode “1920x1080”
geometry 1920 1080 1920 1080 16
timings 0 0 0 0 0 0 0
accel true
rgba 5/11,6/5,5/0,0/0

which does not appear to list any EDID information, but I don’t know what (if anything) I can do about that.



I believe that is because there is no onboard audio codec on the BBB as there is on RaspberryPi.

Strange, as I get audio over HDMI just fine. If I recall though it has something to do with not being able to do 1920x1080 at full 60HZ, and still do audio, seems like it was 40 or something. I’d have to dig through the archives a bit for that.



Can you elaborate on what I should be looking at on that page? As I mentioned in the original post, I have already poured through it. I tried both of the resolutions that it claims support audio over HDMI, with no success. I definitely saw the screen resolution change visually, but no audio was apparent.


Only two resolutions support audio over HDMi. Unless you use one of those two resolutions, you will not get audio over HDMI.


Ok, but as I mentioned in my original post, I have tried both of those resolutions and neither of them produced audio over the HDMI connection. So there must be some other problem that I have to get solved in order to make this work.



I have the same exact problem with Linux beaglebone 4.9.45-ti-r57 #1 SMP PREEMPT Fri Aug 25 22:58:38 UTC 2017 armv7l and Linux beaglebone 4.9.63-ti-r77

I have tried to update the OS, change the resolution, the audio is not working,

The other thing I confirm is that GPIO1.27 is LO it commands the oscillator of the audio I2S, which is in this case disbled.

I guess it s just software as I had it working once by accident (and i don’t know why nor why it does not work anymore)