Cannot get ubuntu install in SD card (beagleboard C4)

Hello,
I have a problem trying to prepare a SD in order to use it on mu
beagleboard, I'll explain it fully:

First I Install Angstrom on a 7Gb SD card. (i make the two
partition... bla bla bla)

I felt prepare to make a step and install ubuntu on the beagleboard.
Then I erase all the data into the partition two on the SD and no
touch the partition one (inside that is the MLO, u-boot and uImage). I
copy the a prebuilt image ubuntu-10.04-minimal-armel.tar.7z (from
http://elinux.org/BeagleBoardUbuntu#Lucid_10.04) so I decide to follow
all the manual step by step (I'm a beginner so strictly step by step,
I'm so obedient).
1: I download on my computer the ubuntu-10.04-minimal...tar.7z,
2: I go to download directory and tipe "7za x ubuntu-10.04-minimal-
armel.tar.7z" and get the *.tar
3: Then I type "tar xf ubuntu-10.04-minimal-armel.tar" and it work
correctly making the directory "ubuntu-10.04-minimal-armer". I get
into this directory typing "cd ubuntu-10.04-minimal-arme"
4: Here is the problem, when I type the next sentence: "./
setup_sdcard.sh --mmc /dev/sdX --uboot beagle_c4" the terminal said:
medel@ubuntu:~/Prueba_Ubuntu/ubuntu-10.04-minimal-armel$ ./
setup_sdcard.sh --mmc /dev/sdb2 --uboot beagle_c4
Are you sure? I Don't see [/dev/sdb2], here is what I do see...
sudo fdisk -l:
medel@ubuntu:~/Prueba_Ubuntu/ubuntu-10.04-minimal-armel$

That my problem, I can't to take this step, I've tried typing:
./setup_sdcard.sh --mmc /dev/sdX --uboot beagle_c4
./setup_sdcard.sh --mmc /dev/sdb --uboot beagle_c4
./setup_sdcard.sh --mmc /dev/sdb2 --uboot beagle_c4
...
(if I type: sudo fdisk -l i get:
medel@ubuntu:~/Prueba_Ubuntu/ubuntu-10.04-minimal-armel$ sudo fdisk -l
...
Disco /dev/sdb: 7948 MB, 7948206080 bytes
255 cabezas, 63 sectores/pista, 966 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x09dd8ec6

Device Inicio Start End Bloques Id Sistema
/dev/sdb1 * 1 51 409626 c W95 FAT32
(LBA)
/dev/sdb2 52 966 7349737+ 83 Linux
end)

but I failed. I'm so frustrated because I don't know what is it
happening!
maybe i need a non format target to install it?

I don't know so much can i do... could you help me? What I'm wrong?

(lot of thanks!)

That my problem, I can't to take this step, I've tried typing:
./setup_sdcard.sh --mmc /dev/sdX --uboot beagle_c4

X stands for fill in with your own value...

./setup_sdcard.sh --mmc /dev/sdb --uboot beagle_c4

This is the correct one ^.

thank so much about your reply.
Unfortunately I've tried using on mi computer these three option:
./setup_sdcard.sh --mmc /dev/sdb --uboot beagle_c4
./setup_sdcard.sh --mmc /dev/sdb1 --uboot beagle_c4
./setup_sdcard.sh --mmc /dev/sdb2 --uboot beagle_c4
(my own value is sdB)

in all these cases end at the next screen:
"Are you sure? I Don't see [/dev/sdb2], here is what I do see..."
but it's really exist.

I'm trying to said that my problem isn't to fill my own value and
actually I can't install ubuntu lucid.

What can I do? shoud I keep trying to install this lucid or maybe
shoud I build my own ubuntu using OpenEmbedded?

Little lag on the group email list.. So for others with this problem
in the future..

Check the "setup_sdcard.sh" script for an improper language localization:

DISK_NAME="Disk|Platte" adding Spanish for Juan solved it..
DISK_NAME="Disk|Platte|Disco"

Regards,